cancel
Showing results for 
Search instead for 
Did you mean: 

Table resets CellEditor's LeadSelection

Former Member
0 Kudos
61

Hi all,

I have a table in which each row has a dropdownbyindex field. These dropdown boxes have preselected values (leadselection). Until here everything works fine and when I load the view every dropdown box has it's correct leadselection.

However, as soon as I select a row from the table the row's dropdown box's leadselection will be reset to -1.

Why does that happen and how can I avoid this effect?

Regards,

Jan

Accepted Solutions (1)

Accepted Solutions (1)

sureshmandalapu6
Active Contributor
0 Kudos

Hi Jan Marquardt,

Write the code to get the value into Dropdownby index in OnLeadSelect event handler. your problem would be solved.

thanks

Suresh

Former Member
0 Kudos

I do not believe that a dropdownbyindex field has an OnLeadSelect event handler. I am using the OnSelect event handler to get the value. However, getting the value of the dropdown box is not my problem. The problem is that the preselection of a row's dropdown box is earased (leadselection is set to -1) as soon as the row is being selected.

Former Member
0 Kudos

One more information: the table's property rowSelectable is already set to false as I really don't want any row to be selectable. Web Dynpro does still allow the user to "shadow select" a row though. Means, the user can still click on the row but then simply nothing happens except that my dropdown box's leadselection is gone.

former_member197348
Active Contributor
0 Kudos

Hi Jan,

the table's property rowSelectable is already set to false 
as I really don't want any row to be selectable.

If you want to disable table's row selection (lead selection), you can modify your table properties like this: this works in nw04s version

compatibilityMode nw04Plus

selectionMode none

Regards,

Siva

Former Member
0 Kudos

> compatibilityMode nw04Plus

> selectionMode none

This solved the problem by making the table's rows truly unselectable.

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi,

I have no idea which dropdown you have used. Use dropdownbykey and bind with the attribute of simpletype. This attribute must be inside the node with which your table dataSource property is mapped. This will work.

Anyhow i dont see any reason why the leadSelection of dropdown is changing on leadSelect of the row in the table.

thanks & regards,

Manoj

Former Member
0 Kudos

>

> Anyhow i dont see any reason why the leadSelection of dropdown is changing on leadSelect of the row in the table.

>

This is the problem that I have and I do not understand why this is happening either.

Former Member
0 Kudos

Hi,

It was just my point of view. Could you please post the context structure you have used. Hope it will help us to catch the problem.

If your dropdown values are static, i mean constant then just give a try what i suggested you in my previous reply.

thanks & regards,

Manoj

Former Member
0 Kudos

The context structure is:


+ Orders
  --> date
  --> product
  + Status (0...n, singleton)
    --> name

The orders are displayed in the rows of the table. Then each row has a dropdownbyindex box where the user can chose the status. The dropdownbyindex box is bound to the context attribute "Status->name".

nikhil_bose
Active Contributor
0 Kudos

see if you have set nodes' initializeLeadSelection property to false.

nikhil