cancel
Showing results for 
Search instead for 
Did you mean: 

Syndication of changes only

Former Member
0 Kudos
56

In the syndicator you can "Suppress unchanged records", I understand this the way that with this feature you will only export changes. when I do the syndication, I se no changes on the exported file if you have this setting or not. Do anyone have any experience with this.

Are the any documentation available for the Syncronator?

Best regards

John-Kjell

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Thank you for all your feedback, I still have a problem.

Under Syndication Properties there are two tick boxes related to "Suppress unchanged record". The first one under the column Reset is grayed out. I suspect this is where my problem is. Is there a setting I am missing. The second tickbox I am able to tick, but i never get the grayed out unchanged records.

Regards John-Kjell

0 Kudos

Hello John-Kjell,

Look at the table settings back in the console. I belive this will only work if "Key Mapping" is set to "Yes" for the table.

Regards,

Karl

Answers (6)

Answers (6)

Former Member
0 Kudos

Oh, I totally agree with you that table level setting needs to be on. But the actual key does not need to be there.

It could probably be that turning on key mapping setting initializes the syndicator's internal last run time tracking.

Former Member
0 Kudos

Hi Karl,

I am curious if you tried out without key mapping. And the reason I say is the following-

As part of my learning efforts during last few months, I tried several scenarios. I have key mapping set to YES on my table. However, when I added a record to the table from client after my first syndication, I did not right click and add the key in the client. I just executed the second syndication, and it did send out the record that I just added.

Thanks

Savi

0 Kudos

Hi Savi,

Its strange, because the system does not seem to require the key mapping data be there, just that the setting is active. I can reproduce the situation by turing the "key mapping" setting off on a table. When I switch it off, the "syndicate changes only" does not function, if I reactivate the setting to "yes" even without having actual keymapping values assigned, the "syndicate changes only" will work. Try it on a test repository, its pretty easy to replicate the problem.

Karl

Former Member
0 Kudos

Hi John,

Suppress records without key is related to key mapping setting in the console. But on the other hand, Suppress unchanged record setting operates on the internal timestamp that syndicator maintains based on when you ran your last syndication. And this Suppress unchanged records should not be grayed out. It is grayed out unless you start with a new syndication from file menu. Could you please try again starting a brand new syndication?

0 Kudos

Suppress unchanged record setting operates on a combination of internal timestamp AND key mapping. This is the case so you can publish to two separate clients on different schedules.

If you activate the “key mapping” on the table and then execute your syndication one more time, the system will now know that receiver obtained those records and they will be grayed out.

Regards,

Karl

Former Member
0 Kudos

Expanding on Ronen's comment- I used this step by step approach to test it when I was learning:

I logged onto syndicator, selected new frm file menu, gave the name, file type of XML, selected xsd, and OK.

Then, selected source table of choice in left pane box; since XML, I have destination items ready. SO, just do the item mapping; define the syndication properties- check suppress unchanged records option.

Hit execute, it asks for destination file name, give a name, your records are syndicated.

Now, execute the syndication again, and you already see that record detail shows all records grayed out meaning that none will be exported during second syndication.

Now I added a record to my table through client, hit F5 to refresh syndicator pane, and executed syndication. 1 record was exported.

if the file type is flat file instead of XML in the first window, every ste p is the same except for :

1) no need to give xsd

2) Need to type your destination items yourself

Good luck!

Former Member
0 Kudos

It is something I am missing, because nothing is grayed out for me.

Former Member
0 Kudos

Do a simple test export 1 record, restart syndicator open the same syndication map make sure “Suppress…” is checked and see if the previously syndicated record, is grey out.

Former Member
0 Kudos

When "Suppress unchanged records" is checked, only records that where changed since the last syndication was executed will be created as XML files. The changes are not reflected in file created, but records which are qualified to this criteria will not be exported, and will be a gray out In the main table view.

Regards,

Ronen