Showing results for 
Search instead for 
Did you mean: 

Selection in the Generic Data Source does not work

Former Member
0 Kudos

Hi gurus,

I have some problem with the selection in the Generic Data Source.

I have created a view as a base of a Generic Data Source.

This view is based on several table; i.e.: VBUK-VBELN (Sales Order number), VBAP-ERDAT (creation date of Sales Order), VBAP-POSNR (Sales order item), VBAK-BSTNK (Customer Purchase order number).

In the view, some join conditions have been defined: VBUK-VBELN = VBAK-VBELN, VBUK-VBLN = VBAP-VBELN.

I want to extract the Sales Order number, Sales order item and Customer Purchase order number for the Sales order created on the previous year.

On the Generic Data Source, I select VBELN (Sales order number) and ERDAT (creation date of sales order) as selection.

However, when I run the extractor checker (RSA3) on this Generic Data Source, the selection does not work at all, i.e.:

eventhough I restricted the Sales order number and/or the creation date of sales order, the generic data source ignores the selection criteria and extract ALL data.

Does anyone ever have similar problem? Did I miss some step in the Generic DAta Source creation? How to fix this problem?

Thanks a lot in advance.

Best regards,


Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

problem solved

Former Member
0 Kudos

Hi Fen,

Just check what is the output you get for the same selection for the view you created.



Former Member
0 Kudos

Hi Dinesh,

The view works fine. If I restrict the Sales Document number and/or the Creation Date, then the view will only show me the Sales Documents within my restriction criteria.

Former Member
0 Kudos

Problem solved.

The field "Field known only in Exit indicator" must be deselected manually using RSA6.