cancel
Showing results for 
Search instead for 
Did you mean: 

Save default spool retention days to 15

rohitsharma1981
Participant
0 Kudos
421

Dear All,

Is it possible to save the default spool retention days to 15? If yes, how?

I tried to understand note 64333 and 1908179. But still confused.

I am using SAP version 7770.1.8.1162, patch 8.

Many thanks in advance.

2023-02-22-11-43-53.png

Accepted Solutions (0)

Answers (4)

Answers (4)

S_Sriram
Active Contributor
0 Kudos

Hi Sharma Ji

1. Use the transaction code SA38 and select the program name RSPO0041 & select the "Overview of Variant" to create the new variants

2. In SM37 Steps you can select the program name and select the newly created variant.

Regards

SS

rohitsharma1981
Participant
0 Kudos

Thanks SS for your feedback and apologies for taking your too much time. I'm new to SAP world.

If I try to implement your recommended solution, it will impact for all the users. Right?

Is there a way if it can be implemented for particular user id as the change is asked by a particular department.

Many thanks!

raymond_giuseppi
Active Contributor
0 Kudos

Change rspo/req_lifetime, AFAIK the old note mentionned in many old threads is no longer relevant (for some years)

ref: 1908179 - Changing default value for spool retention period

rohitsharma1981
Participant
0 Kudos

Thanks Raymond. We are not using rspo/req_lifetime

S_Sriram
Active Contributor
0 Kudos

Hi Rohit

You can create a new job calling RSPO1041 with a new variant of 15 days.

Regards

SS

rohitsharma1981
Participant
0 Kudos

Thanks SS!

What if I set the spool retention to "Do not delete" and modify RSPO0041, RSPO1041 to set MIN_ALT = 15.

Will it work?

S_Sriram
Active Contributor
0 Kudos

Hi Sharma Ji,

Have you tested the development or quality system?

Regards

SS

rohitsharma1981
Participant
0 Kudos

Hello SS,

I am trying to save the option "Do not delete" (SM37 -> Enter job name & Execute -> Click on Step > From List menu -> Print -> Properties -> Output option -> Spool retention -> Double click and set Do not delete).

Somehow it is not getting saved. Any idea?

Neeraj_Jain
Active Contributor
0 Kudos

Hello rohitsharma1981,

Please refer below accepted SAP thread on same issue.

https://answers.sap.com/questions/2254523/how-to-set-the-spool-retention-period-till-30-days.html

Regards,

Neeraj Jain

rohitsharma1981
Participant
0 Kudos

Thanks Neeraj!

The thread mentioned by you is asking to refer note 64333, which I already did.

In the note it is mentioned, numbers with two digits cause conflicts in the R/3 kernel.