cancel
Showing results for 
Search instead for 
Did you mean: 

SAP XI 3.0 integration Builder

Former Member
0 Kudos
85

Hi,

I am unable to start SAP XI 3.0 integration Builder, whenever I try to start it from SAP displayed with a message Integartion Builder Address not Maintained.

I am unable to open the page

http://ipaddress:50000/irj

Error Message:

404 Not Found

SAP J2EE Engine/6.40

The requested resource does not exist.

Thanks & Regards,

Prashanth

Accepted Solutions (0)

Answers (7)

Answers (7)

former_member556603
Active Contributor
0 Kudos

Hi,

Error: 404 Not Found

Description: The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address. This status code is commonly used when the server does not wish to reveal exactly why the request has been refused, or when no other response is applicable.

Possible Tips:- for HTTP_RESP_STATUS_CODE_NOT_OK 404

u2022 404 is an HTTP response code that indicates that the resource in question couldn't be found. Usually this is due to an incorrect URL, so it is better to cross check all URLs. Check pipeline URL in the SLD in the business system of the Integration Server For this go to SLD->Business System-><yourIntegrtaion Server>->Pipeline URL: It should be like this http://<host>:<port>/sap/xi/engine?type=entry Where host is the host name of the Integration Server and port is the HTTP(8xxx) port. To verify this in Integration Server you can do like this. Go to SXMB_ADM->Integration Engine Configuration->Choose Edit from Menu -> Change Global Configuration Data to switch to change mode. Then select System Landscape - Load Configuration. (This is not required always)

u2022 Check that the port really is the ICM HTTP Port and not the J2EE port i.e SMICM then menu GOTO --> SERVICES and check the port number for HTTP. It should be HTTP port

u2022 If the error is Page cannot be displayed, cannot find server in https configurations Check and correct the SSL configuration for the ABAP and the J2EE side of the system

u2022 If the error is because of integration server when using Proxy communications then check these. i.e SXMB_ADM->Integration Engine Configuration->Corresponding Integration Server enrty should be dest://<Http Integration server-Destination> Where < Http Integration server -Destination > is the RFC destination (SM59) of type HTTP connection (type H) to the Integration Server. In this case, host name, port, and path prefix are saved in the RFC destination.

Former Member
0 Kudos

hi prashant

check the below blogs

*Trouble logging to Integration Builder ( IR / ID ) ? *

/people/shabarish.vijayakumar/blog/2006/02/13/unable-to-open-iresrid-xipipi-71-updated-for-pi-71-support * *

*Unable to open Integration Builderu2026checklist *

https://www.sdn.sap.com/irj/sdn/weblogs?blog=/pub/wlg/1688 [original link is broken] [original link is broken] [original link is broken]

regards

chandrakanth

former_member184619
Active Contributor
0 Kudos

Hi,

Make an entry for XI server IP address in Host file

C:/Windows/System32/drivers/etc/host

open it in notepad and at end of file give IP address, press TAB and give the hostname

10.100.7.622 (TAB key) hostname

and check these blogs:

https://www.sdn.sap.com/irj/sdn/weblogs?blog=/pub/wlg/1688 [original link is broken] [original link is broken] [original link is broken]

/people/shabarish.vijayakumar/blog/2006/02/13/unable-to-open-iresrid-xipipi-71-updated-for-pi-71-support

Regards,

Sachin

Former Member
0 Kudos

Make sure the following setting are done in Java Web Start.

To change the Proxy Settings:

Select Windows Start menu -> All Programs -> Java Web Start -> Java Web Start

Choose File -> Preferences -> General

Choose None to switch off the proxy settings or Manual to set the HTTP Proxy and HTTP Port.

ChooseOK

Close Java™ Webstart

Former Member
0 Kudos

Hello,

Check this...

https://www.sdn.sap.com/sdn/weblogs.sdn?blog=/pub/wlg/1688 [original link is broken] [original link is broken] [original link is broken]

Former Member
0 Kudos

Hi,

This is URL for Exchange Infrastructure Tools

http://<Server-Host>:<J2eePort>/rep/start/index.jsp.

Otherwise,

In ABAP stack execute the TC: sxmb_ifr

Thanks.

Boopathi

Former Member
0 Kudos

Hi,

Maintain the XI host entry in the below path.

C:\WINDOWS\system32\drivers\etc\hosts

IB url is wrong....use the correct one ....

chirag