Showing results for 
Search instead for 
Did you mean: 

SAP Web IDE: 503 Service not available


Hi all,

SAP Web IDE, XS Advanced Administration, briefly stated all https://hxehost:510xy apps worked quite well up to now.

However recently I always get the "503 Service not available" message. Checking with xs apps shows that the apps mentioned above all started, but the instances column shows 0/1. When trying to restart e.g. via xs rs webide the result shows the state CRASHED instead of RUNNING.

What's the reason? Might it be a memory issue? I run HANA Express 2.0 SP01 on a VMWare on a notebook with 16 GB RAM.

Thanks, Ingo

0 Kudos


I am facing the same issue. did you resolve that issue or not? For me I have enough memory.



Active Participant
0 Kudos

Hi Mohamed,

If you have enough memory, then it's probably just a matter of giving the service a bit more time to start up.

Try waiting about 5 mins, and then type the command xs apps | grep webide without restarting any service. Hopefully, it should show as 1/1 after a few minutes at the latest.

Let us know if this works for you.


Accepted Solutions (1)

Accepted Solutions (1)

Former Member

Hi ,

I came across same issue and noticed that after you start your VM you need to wait 10-15 min and then Webide will start on port 53075.



Answers (1)

Answers (1)

Product and Topic Expert
Product and Topic Expert

Hi Ingo,

You are right: probably a memory issue.

Computer with 16 GB RAM, take off 4 GB for the OS, leaves ± 12 GB for HANA. This will allow only for the server-only image.

On the cloud-hosted version, the template for server-only is set to 13 GB of RAM, for server+apps it is 26 GB.

The +apps part, the XSA environment add the different runtimes for the hosted applications.

For the server+apps VM, you would need a NUC, see for example