cancel
Showing results for 
Search instead for 
Did you mean: 

SAP RPA agent login successful but can not activate tenant

ygrandclement
Explorer
0 Kudos

2023-11-12-16-54-33.jpg2023-11-12-16-54-35.jpgHi

I used the SAP RPA agent version 2 something to create automation scripts for BTP Process Automation in SAP Build a couple of months ago successfully, around June-July I believe. I recently tried to use it again, starting by upgrading to version 3.21, but I can not register to my tenant anymore. I have tried all posts I found here and elsewhere, deleting and un-installing everything and trying again fresh, restarting often, but still no luck.

My issue is that I can add my Process Automation tenant in the RPA agent. When I try to activate it, I can log in via the pop-up, and the pop-up tells me the login is successful (screen shot), but the tenant does not activate. In the RPA agent logs, it says my login failed (second screen shot). Any ideas?

Yann

Accepted Solutions (1)

Accepted Solutions (1)

ygrandclement
Explorer
0 Kudos

I finally figured it out. We had a corporate global policy update a couple of weeks ago that updated the settings on the FW agent on devices. With the help of network and Cyber teams, we created an exclusion in the FW agent rules to prevent automatic SSL inspections on connections with the FW certificate, and this solved the problem. The agent can now activate (authenticate fully) with the PA tenant. I hope this helps others.

Answers (3)

Answers (3)

Venkat_Vyza
Active Participant
0 Kudos

Hi,

Please follow these instructions and register your Agent with the Tenant. Then try.

https://help.sap.com/docs/intelligent-robotic-process-automation/installation-guide/desktop-agent-te...

Thank you,

Venkat Vyza

Venkat_Vyza
Active Participant
0 Kudos

Please share the print screen of the Agent Tile under control tower.


Thank you,

Venkat Vyza

ygrandclement
Explorer
0 Kudos

Here you go, agent does not come up in the control tower (I can not activate the PA tenant from the desktop agent)

2023-11-13-11-24-33.jpg
Venkat_Vyza
Active Participant
0 Kudos

Hello @ygrandclement,

Do you see the Agent connected under Agent Tile (Control Tower)?

Thanks,

Venkat Vyza

ygrandclement
Explorer
0 Kudos

Hi venkat_vyza no the agent does not show up in the control tower. I believe it is an issue with my work laptop, because I tried with a personal computer and it worked. I checked the proxy settings as per similar troubleshooting tickets and seems fine, and also added my PA tenant as secure site, but still does not help.

I manually created an agent group and manually added my machine, but it did not help either.

Yann