cancel
Showing results for 
Search instead for 
Did you mean: 

Run Time error : Load_Type_Verson_Mismatch issue.

mv1985
Participant
0 Kudos
312

Hello,

Recently we faced two issues in our data loading from ECC to BI systems:

1. IDOCs getting stuck in [ SM58 ] in source ECC system and needs to be manually processed for all the processes [ Info Package ] in process chain . It was showing DB >> ERROR >>0 and Destination None , but manually processing it executed it with correction BI destination from ECC system

-- This issue is not there as of now but keeping a watch for it.

2. We have process chain with 270 steps and many Info Packages scheduled in it , after the 1st issue, now this issue has emerged

-- As soon as InfoPackage JOB gets scheduled it goes red ( 50 - 60 % of the times ) and checking error it says : Job cancelled in source system :

-- Checking in source system ST22 it says : Load_Type_Version_Mismatch, restart the program, The Abap runtime system detected that the dictionary-type ' HRMS_BW_IS_ATTENDANCE' changed.

-- Sometimes restarting twice or thrice or even fourth time, it works

--- But doing so for so many info-packages seems impossible as it needs constant monitoring.

EX: we have many datasources with monthly infopackages in each of them like DataSource A has 12 Infopackages for each month of 2014.

Some infopackages run fine but some as soon as gets scheduled turns red with that message as mentioned above . So it's a very random thing but happening frequently.

This issue emerge all of sudden in last 4-5 days and for the last 6 months it wasn't there

Please suggest on issue 1 and especially 2nd as it's still there . I have contacted basis team for this.

Regards,

Accepted Solutions (0)

Answers (1)

Answers (1)

RafkeMagic
Active Contributor
0 Kudos

issue 2 is linked to a change in the InfoSource... so, did someone "refresh" the business content? in that case you might have to reactivate DataSources/InfoSources/... these "structures" usually don't change by themselves, so you need to find the root cause of this change first

I'm assuming issue 1 is linked to the same root cause

mv1985
Participant
0 Kudos

Hi Raf,

What do you mean by 'refresh' the business content ? We have already re-activated datasources/infosources because ECC was patched and so system gave 'TIME-STAMP' error and prompted to reactivate the datasources. After that system was fine.

But does repeating the info-package it works fine and sometimes there is no error at all just random.


I will again confirm it if BI was patched too.

Thanks

RafkeMagic
Active Contributor
0 Kudos

I meant (re)install/merge... anyways, the error you get on the InfoSource means there is a mismatch (so difference between source system and BW).

Just guessing some things were actually changed in the source system and not correctly dealt with. I would replicate the DataSources that are giving issues and make sure the entire flow is activated again.

mv1985
Participant
0 Kudos

Hi Raf,

I have replicated the DS and re-activated the whole structure . In few minutes process chain will be triggered and lets see how it goes .

I have checked runtime errors in ECC system, it seems HRMS_BW_IS_ATTENDANCE structure is not in consistent state and might require some type of re-generation ? Just a guess.

Thanks,

MV

mv1985
Participant
0 Kudos

Issue still persists even after replicating datasource and re-activating the whole flow.

RafkeMagic
Active Contributor
0 Kudos

that's what I have been saying... your (InfoSource) structure has changed, so again try to find the root cause for this change

mv1985
Participant
0 Kudos

So can you please suggest to find the root cause..which areas I should look for in sequence.