cancel
Showing results for 
Search instead for 
Did you mean: 

Reg: Parameter Value help text not appearing

Former Member
0 Kudos
275

Hi All,

We are on SPS 10.

I have created a Calculation view which has Vendor id and Vendor description fields. Vendor Description is assigned as label column to vendor id at semantic level.

Parameter IP_VENDOR is used to filter the vendor value and it has master data attribute view assigned as value help table.

After I execute the Calculation view when I hit value help button I see only vendor values, the corresponding description doesn't appears.

Could you please suggest?

Regards,

Venkat

Accepted Solutions (1)

Accepted Solutions (1)

former_member182302
Active Contributor
0 Kudos

When creating your Attribute View , Just add the description label column to the Label in the below screenshot

Then you should be able to see the description appearing

Regards,

Krishna Tangudu

Former Member
0 Kudos

Hi Krishna,

I already did that but I still don't see description.

Regards,

Venkat

former_member182302
Active Contributor
0 Kudos

Am currently using HANA SP10, and I just tried doing it. I created a attribute view and defined the label for the column

And in the Input parameter, I used "Derived from Column" and mentioned the attribute view .

On the data preview , am seeing the description along with the columns

Regards,

Krishna Tangudu

Former Member
0 Kudos

Hi Krishna,

Thanks for your time, no it still doesn't works for me.

I will try to explain my view in below steps.

Step1:

Inner Join between Purchase order Item and Header table (EKPO and EKKO). Parameter is assigned to the vendor field of EKKO.

Step2:

resultant of step 1 is text Joined with the attribute view based on the LFA1 table.

(Attribute view has the Label column mapped to vendor description).

Step3:  Resultant of the Step 3 is passed to default aggregation node of calculation view and from there to semantics.

Problem description:

When I do data preview on any of the nodes below the default aggregation node and click the value help button, I get both Vendor Id and Vendor Description.

When I do data preview at default aggregation node or at the over all calculation view level and click the Value help button I get vendor id but description don't show up.

Regards,

Venkat

Former Member
0 Kudos

Hi All,

I was able to resolve the issue.

Initially I was assigning the value help view at the parameter level and also at the field semantic level highlighted below. Though I was assigning the same view at both levels the description was not showing up.

Description started appearing once I removed the value help views which was assigned at the semantic level of the field.

Answers (0)