cancel
Showing results for 
Search instead for 
Did you mean: 

"KEEP VERSION" does not appear in IS_SELECT phase during Upgrade

0 Kudos

We are currently doing an upgrade and we came to the phase where we need to make a decision for Best Practice Add-On. My question is, why is the "Keep the current add-on version" option does not appear.

Only the Upgrade and Delete option.

Thank you in advance!

Expectation

Current options available

patelyogesh
Active Contributor
0 Kudos

Hello Maria B,

Do you know what component are you working with?

-Yogesh

0 Kudos

Hi Yogesh,

We are actually doing an upgrade of the following:

Current version:
SAP Netweaver 7.5 SPS07
CARAB 2.0 SPS01

Target version:
ABAP FND 1809 ON HANA FPS 02
ABAP PLATFORM 1809
SAP CARAB 4.0 FPS01

When we create the stack file, these two components are not chosen nor appearing in the options to be upgraded.

BP-CANW 750V3 0 - Tech. Obj. for SAP BP pkg. act. based on BP-SOLBLD 70VA 0 - Best Practices Solution Builder on EHP5

During the IS_SELECT, they have undecided status and when I try to choose, there is not an option to KEEP_VERSION. Only Upgrade and Delete. When I try to Upgrade OR Delete, it is looking for a package in SAINT. Now, I added the upgrade files, but we are getting OCS package does not match the software component vector for package SAPK-755AGINBPCANW. I tried searching for ACP for this package, but there is none in Software Download Center.. Plus the BP-SOLBLD upgrade files didn't pass the prerequisites.

Accepted Solutions (0)

Answers (3)

Answers (3)

0 Kudos

Hi everyone,

Indeed the best practice packages was removed by doing a copy of QA system, which does not have these two add-on and proceeded with the upgrade. SUM was reran and was able to proceed.

Thanks to all who replied.

patelyogesh
Active Contributor
0 Kudos

Hello Maria B

Hope this system is not your production system.

You can simply ignore them and continue with upgrade selecting delete. (Hope it works without any issue). Make sure you have full backup of system (just in case)

Both seems best practices packages and you can delete them from the system. Generally you do not need them in system and they are additional maintenance.

Please let me know if you have more question

Best,

Yogesh

SAP note to look for : 1720750

S_Sriram
Active Contributor
0 Kudos

Hi Maria.

Before selection check the add on supported upgrade sap version or not? if possible share the SAP upgrade and add on version details.

Regards

SS

0 Kudos

Hi S Sriram,

We are actually doing an upgrade of the following:

Current version:
SAP Netweaver 7.5 SPS07
CARAB 2.0 SPS01

Target version:
ABAP FND 1809 ON HANA FPS 02
ABAP PLATFORM 1809
SAP CARAB 4.0 FPS01

When we create the stack file, these two components are not chosen nor appearing in the options to be upgraded.

BP-CANW 750V3 0 - Tech. Obj. for SAP BP pkg. act. based on
BP-SOLBLD 70VA 0 - Best Practices Solution Builder on EHP5

During the IS_SELECT, they have undecided status and when I try to choose, there is not an option to KEEP_VERSION. Only Upgrade and Delete. When I try to Upgrade OR Delete, it is looking for a package in SAINT. Now, I added the upgrade files, but we are getting OCS package does not match the software component vector for package SAPK-755AGINBPCANW. I tried searching for ACP for this package, but there is none in Software Download Center.. Plus the BP-SOLBLD upgrade files didn't pass the prerequisites.

0 Kudos

Hi Sriram,

We are actually doing an upgrade of the following:

Current version:
SAP Netweaver 7.5 SPS07
CARAB 2.0 SPS01

Target version:
ABAP FND 1809 ON HANA FPS 02
ABAP PLATFORM 1809
SAP CARAB 4.0 FPS01

When we create the stack file, these two components are not chosen nor appearing in the options to be upgraded.

BP-CANW750V30-Tech. Obj. for SAP BP pkg. act. based on
BP-SOLBLD70VA0-Best Practices Solution Builder on EHP5

During the IS_SELECT, they have undecided status and when I try to choose, there is not an option to KEEP_VERSION. Only Upgrade and Delete. When I try to Upgrade OR Delete, it is looking for a package in SAINT. Now, I added the upgrade files, but we are getting OCS package does not match the software component vector for package SAPK-755AGINBPCANW. I tried searching for ACP for this package, but there is none in Software Download Center.. Plus the BP-SOLBLD upgrade files didn't pass the prerequisites.