cancel
Showing results for 
Search instead for 
Did you mean: 

"Intervals in Hierarchy" Any Performance Implications ???

Former Member
0 Kudos
421

Hi,

Is anyone aware of any performance implications in reports when we filter on a hierarchy which has a lot of interval nodes.

This is what we are encountering. We have a hierarchy on Account Group in which all nodes have interval ranges. We added this hierarchy in a query.

When we do not do any filtering on the nodes of the hierarchy (Time Independent) and let it run for the complete hierarchy, the query runs fine and retuns in about 2 minutes.

We run this query again, keeping all things exactly the same, but do "fix filter value to axis" on a node of the hierarchy. When we do this, query runs for about 45 minutes...

We have repeatedly seen this behavior with different nodes of the hierarchy. I have not tested with a hierarchy that doesn't have hierarchy nodes...(currently working on that)

I looked in OSS notes, didn't find anything useful, but, I might have missed something...

Please post your comments if you have seen any behavior like this.

Thanks alot

Gova

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hi Gova,

no personal experience about that, but there is an OSS Note (738098 'Performance problems with hierarchies') probably useful (but not so much !)

Bye,

Roberto

Former Member
0 Kudos

Roberto,

Thanks for the reply. Checked out the note, doesn't seem to be addressing this issue...here are more details about the hierarchy and how we are using this in the query. May be you can smell a clue there...

The infoobject (on which the hierarchy is built) is a NAV attribute in the query. (NAV attributes slow down the processing, but its slow only when there is an active filter.) Since this hierarchy contains ranges, it has to access additional "J Table". Another table to access, Another reason to slow it down. But again not sure why only when the filter is present.

Could that be because of the way BW formulates the select statment? Is there a way we can mess(!) around with this? Will check to see what ST05 trace reveals, but not sure if that helps with anything.

Thanks

Gova

Former Member
0 Kudos

go in and increase the rsdb/obj/buffersize and after the instance is restarted it should work. This setting needs to be at lease 20000. the default is 4096. We are testing with the setting at 40000. Its dependent on your hardware setup.

Ok, if this still does not help you can goto "maintain hierarchy attributes" and after chooing your hierarachy check the box that says something like "igonore unnassigned nodes". Do this at the hierarchy level and NOT the query level. If you have lots of master data records that are not in your hierarchy this will dramtically reduce the query run time.

Thanks

Richard