Showing results for 
Search instead for 
Did you mean: 

Proxy Settings for WebService invocation

0 Kudos


I have a bean which is exposed as a WebService on WebAS on a machine A. Within this bean, I call another WebService, which is NOT running on WebAS but on Axis on another machine B.

For the call to the WebService I have NOT generated a proxy in Netweaver Developer Studio, but have created the Stub with Axis WSDL2Java tool. (When I tried to generate the proxies in Developer Studio it would say there was a problem during generation, without giving any details).

When I call the Axis WebService from a browser on machine A, everything works fine, provided that I've set the right proxy settings.

I can also use the generated Stubs to call the service. However, when I call it from within the beans running in WebAs, I get a timeout, obviously due to inadequate proxy settings in WebAS.

Now, I've searched through the administration guide and tried to do the configuration as described in

But this showed no effect. I also restarted the server to ensure that the configuration is updated properly.

(As a test I also tried to change the WS Clients Socket timeout, but for some reason this timeout did not change when I had restarted the server and tried the Web Service again (from Web Service Navigator). So I don't even know if I am configuring the right settings..)

Does anybody have an idea what I'm doing wrong or which other configuration I might have to set?

Thanks alot for any help..


Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Hello Katrin,

did you solve your problem mentioned above?

If yes, could you please describe me, what kind of settings you have made in the visual admin to test the webservice without connection time out?

Thank you in advance for your help.

Kind regards, Patrick.