Showing results for 
Search instead for 
Did you mean: 

Problem in Internalization( I18N) for changing the Source langeuage

Former Member
0 Kudos

Hi All,

I have some problem in changing the source language in header:

In S2X editor, I copyed the .xlf file pasted in same then modifyed accordingly(xxx_de.xlf) when i opend the xlf its asking the Activity when I created its throwing repository access faild like no deltaV resource avilable with directory(c:\......)

and im not able to change the header and Resource text In S2X Editor, any one give me help on this.



Accepted Solutions (0)

Answers (3)

Answers (3)

Former Member
0 Kudos

Problem is resolved.

Thanks for all


Former Member
0 Kudos

Hi Nagesh,

When we are doing I18N for that Application. Go to Navigator Tab

Here Select Particular Projects--à src-àPackages-àsap-àvijay

To internationalize the Web Dynpro application, copy the automatically generated *.xlf files and save them under a new name in the same directory.

The new name must meet the following convention:

u2022 .xlf

For example, if you are creating *.xlf files for German,

Use the language key de.

Here Click on OK

After that we can edit and translate these new *.xlf files in the S2X Editor.

ApplyTemFirstView.wdview_de.xlf-àClick on Resource Text Tab

Select Particular Text and Change the language to German-àClick on EDIT Button

Here Enter German Lang-àClick on OK

Now Go to Web Dynpro Explorer Tab

Select Project-àRC Click on Rebuild Project

Select Project-àRC Click on Reload

Then Deploye the Application

How to Check in Explorer. It is converting to German Language or not

Open Internet Explorer

Tool-àInternet Options -àClick on Languages Button-àClick on ADD Button

Select German Language--àClick on OK

Now We will Check in Portal

Created Web Dynpro iView in Portal. That iView assign to the particular WorkSet-àAssign to Role

Select that user Can Change Language


Vijay Kalluri

Former Member
0 Kudos

Hi Vijay,

I done all wt u told but My problem is:

I tryed earliar the same in local workspace its working fine but not existing projects when im apply this to existing application its not allowing to change language in S2X editor(created activity for this but still same problem).


Former Member
0 Kudos


After copying and pasting the original .xlf file. First change the language of the copied Xlf file then make the changes.

Best Wishes

Idhaya R

Former Member
0 Kudos

Hi Idhaya,

I done what you told but read the problem clearly please...