cancel
Showing results for 
Search instead for 
Did you mean: 

PI and CRM connectivity

Former Member
0 Kudos
452

HI Experts,

I want to test the connectivity between PI and SAP CRM system
.

Below are steps I followed:

1)Created ICO in PI and XI receiver channel(XI 3.0) Target URL: http://CRMHOST:8000/sap/XI/engine?type=entry with user authentication(USER with SAP_ALL )

2)Created and tested successfully destinations type G SAP_PROXY_ESR and PI_AAE in SM59of CRM system.

3)Created and tested successfully destinations type  T SAPSLDAPI in CRM system with Registered Server Program defined in NWA JCO (Program ID is running fine in JCO) and Gateway host and service of CRM system.

4)Activated all services in SICF.

5)Created 2 parameters as below: in INtergration Engine Configuration in SXMB_ADMof CRM system

RUNTIME ENGINE_TYPE LOC

RUNTIME IS_URL dest://PI_AAE

6)SLDCHECK and SLDAPICUST working fine.

But I am getting error in XI Receiver channel "BubbleException: HTTP Response Received.Status Code = 500[null "null']'

2 questions:

1)have I missed any configurations/setting?

2)Proxy is not generated yet in CRM system, is it necessary that proxy should be generated and activated in CRM system than only messages will flow from PI?

Waiting for your valuable inputs.

Regards,

SarVjeet

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi all,

Once I have generated and activated the proxy objects(data type , message type and service interface) in CRM system.

All working as expected , PI is able to send messages to CRM and I can see these messages in sxmb_moni of CRM system.

Closing the thread.

Regards,

Sarvjeet

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Experts,

As mentioned earlier, I have one doubt:

Proxy objects(Data type , message type and Service Interface) are not yet generated in CRM system,

Is it necessary to activate these proxy objects in CRM system(sproxy) for messages to flow from PI?

Can you please share your inputs on this?

Regards,

Sarvjeet

Former Member
0 Kudos

Sarvjeet,

  The user which is being used to connect HTTP destination, in that user you need to add

  service interface proxy.

  For Ex: ABC is HTTP dest and  user EFG is using to connect ABC then you need to add proxy name

  in user EFG.

  Goto SPROXY and double click on service interface then you will get proxy name like ZII**********.

  add this in user EFG under role.

Regards,

Bhaskar

Former Member
0 Kudos

Hi Bhaskar,

Proxy objects are not generated yet in CRM system.

I am just testing the connectivity that if messages are flowing from PI to CRM system.

Regards,

Sarvjeet

azharshaikh
Active Contributor
0 Kudos

Hi Sarvjeet,

AFAIK - If you are able to Ping / test your SM59 connections Successfully - SAP_PROXY_ESR and PI_AAE from CRM to PI then should be fairly good to conclude that connectivity is well established betw the 2 systems.

Also at the receiver end, you are able to open the URL and login using the CC User ID / password.

Seems connectivity is working fine and dev can proceed. If you get any further errors while posting actual data, then you can try to debug and fix it then.

Regards,

Azhar

Former Member
0 Kudos

Hi Experts

Any hints please?

Regards,

Sarvjeet

former_member184720
Active Contributor
0 Kudos

Did you try accessing the URL(http://CRMHOST:8000/sap/XI/engine?type=entry) in browser with the credentials configured in the channel? is 8000 the correct port? (u can find it in smicm)

Former Member
0 Kudos

Hi Hareesh,

Yes, port 8000 is correct and I am able to access the URL; Screenshot below:

Regards,

Sarvjeet

former_member184720
Active Contributor
0 Kudos

Hmm.. May be trace it further with XPI inspector and see if you can find additional information.

Former Member
0 Kudos

Hi Hareesh,

As mentioned in original post, I have one doubt:

Proxy objects(Data type, Message type and Service Interface) are not yet generated in CRM system , is it necessary to activate these proxy objects in CRM for messages to flow from PI?

Is this could be reason for error in XI receiver channel?

Can you please share your inputs on this.

Regards,

Sarvjeet

azharshaikh
Active Contributor
0 Kudos

Hi Sarvjeet,

Please check following for similar issue:

For 2.Proxy is not generated yet in CRM system, is it necessary that proxy should be generated and activated in CRM system than only messages will flow from PI?

>>> AFAIK its Not required, you can still post the message..it will fail in sxmb_moni of receiver

Regards,
Azhar

Former Member
0 Kudos

Thanks Azhar,

I have already checked the threads.

Unfortunately getting the same error.

Regards,

Sarvjeet

azharshaikh
Active Contributor
0 Kudos

Hi,

Are you able to ping the Receiver  SOAP Comm Channel to CRM successfully from Communication Channel Monitoring - Ping Channel Test option?

Not sure if you can post dummy data as the one that you are trying...

Regards,

Azhar

Former Member
0 Kudos

Hi Azhar,

Yes , Ping is successfully to CRM system in communication channel monitoring.

Regards,

Sarvjeet

azharshaikh
Active Contributor
0 Kudos

Hi,

Can you try to post valid test data...

Create sample End to End Scenario and test...

are you using Standard SAP content of CRM for dev...u can try to configure it and test.

Regards,

Azhar