cancel
Showing results for 
Search instead for 
Did you mean: 

OData gets different results

former_member699616
Discoverer
0 Kudos
218

I have an odata service with an entityset Employee. I binded this entityset in my ui5 app in a table. Now the problem is that I get different sets everytime. When I test it in SAP GW, it works perfectly. I have 10 entries and everytime I call the get method, I receive all my 10 entries, but in my ui5 view, I get random entries. For example one time I get 7 out of 10, one time all of them, one time 5 out of 10 and so on. It is never the same. Do you know why this can happen?

Accepted Solutions (0)

Answers (2)

Answers (2)

dhiraj_more
Participant
0 Kudos

yeah Right it shouldn’t affect. Then next what i you can do is run Odata URI from network tab directly into gateway and check how many records you are getting. Also try to debug in backend logic might be getting filtered on some criteria may be roles specific or user specific.


Thanks,

Dhiraj M

former_member699616
Discoverer
0 Kudos

We also did that, we took the URL and checked it in Gateway and in Gateway it works just fine, all the data are displayed in the result everytime

dhiraj_more
Participant
0 Kudos

Hi,

Normally result-set for odata call differs based on filters or client side paging(skip,top). Just check the Url by pressing F12(inspect element) and check odata uri in network tab. You will get the clue there only.


Thanks,
Dhiraj

former_member699616
Discoverer
0 Kudos

Hello,

Thank you for the answer.

I checked the url and it had skip 0 and top 100, but I only have 10 entries so it shouldn't be affected, right?