cancel
Showing results for 
Search instead for 
Did you mean: 

No Process Composer or Process Development Perspective in Eclipse 7.5

Former Member
0 Kudos

Hello Experts,

I installed Eclipse 7.5 for designing BPM process, but I cannot see the Process Composer or Process Development perspective in it. Can someone please help me on this?

Really appreciate your help as its very urgent.

Thanks in advance

Accepted Solutions (0)

Answers (6)

Answers (6)

former_member670154
Discoverer
0 Kudos

SAP PO - NWDS 7.5 needs only SAP JVM. Does not work properly with Oracle JDK/JRE. So download the same /take help from Basis team to get all the perspectives visible for BPM

former_member190293
Active Contributor
0 Kudos

Hi!

NWDS 7.5 works fine with Oracle JDK with all required perspectives visible.

Regards, Evgeniy.

Former Member
0 Kudos

Hello Priyanka,

one thing to mention here is that I am trying to install it on the remote desktop. I corrected the JDK means I installed the Jva version that I am using on my system. Is it correct? But I am still getting this errorjava-error.png

My question is that is this java mismatch the reason why the process modelling and process development perspectives are not visible, is yes how to fix this java error?

Really appreciate your help as its very urgent.

Thanks in advance

former_member670154
Discoverer
0 Kudos

Hello BPMFresher,

Did you find solution ? Even i am facing the same issue. No Process Composer is visible after installation of NWDS 7.5 downloaded from the SAP site.. SP16

-Mahesh

Former Member
0 Kudos

Hi Priyanka,

I corrected the JDK but its still the same issue. Can you please advise on this? I tried with all the possible versions but still issue is there.

Thanks in advance

PriyankaAnagani
Active Contributor
0 Kudos

Do you see "Process Modeling" and "Process Development" perspectives? Make sure you are using the correct Eclipse version.

I'm using Eclipse 7.5 SP7 and able to design BPMs using the Process Modeling and development perspectives.

--Priyanka

eclipse-screenshot.png

Former Member
0 Kudos

Hello Priyanka,

I cant see these perspectives in my Eclipse installation I tried with several 7.5 versions but no luck

Can you please suggest me a particular version wherein I can get these perspectives?

Thanks in advance

PriyankaAnagani
Active Contributor
0 Kudos
The NWDS version you need to use depends on your PI version. Check the link provide by Gabriel in the earlier post and download the respective Eclipse version for you. The screenshot I provided earlier is from Eclipse 7.5 SP7.

--Priyanka

Former Member
0 Kudos

Hi Priyanka,

I am using the URL provided by Gabriel for downloading the NWDS.I am using PO7.5 SP05 and tried with the one you suggested but no luck.

But one thing to mention here is that I am getting this error pop up, is this the reason the perspectives are not visible

error.png

Thanks in advance

PriyankaAnagani
Active Contributor
0 Kudos

The error indicates that you don't have Java SE Developmentkit installed. Please install it and make sure the JDK version is compatible with your PI/PO version.

Then, in Eclipse, Windows-->Preferences - configure your PI/PO system details under "SAP AS Java" and also the process composer.

--Priyanka

former_member254784
Participant
0 Kudos

Hi there,

Be sure that you've downloaded https://wiki.scn.sap.com/wiki/display/Java/NWDS+Download+Links

with the link above.


Thanks!

Gabriel

Former Member
0 Kudos

Hello Gabriel,

I am using the same link for downloading the NWDS and following the URL for version 750 as mentioned in the URL

Can you please advise on this?

Thanks in advance

Former Member
0 Kudos

Hello Experts,

Replying in the hope of some help.

Thanks in advance