cancel
Showing results for 
Search instead for 
Did you mean: 

Navigation issue with a Fiori RAP application

luigichiappini
Discoverer
0 Kudos
629

Hi everyone,

I work on a RAP application (oData V4) and I am facing a problem.

I have one root view entity and multiple child entities.

When I preview the app in Eclipse, no problem when I use the 'Create' action on the first page i navigate to the object page. When I use the 'Create' action on the object page for child entites, no problem I navigate to the child object pages.

Object page :

The problem is in the deployed application, when I use the 'Create' action on the first page, I navigate to the object page but when I use the 'Create' action on the object page for child entites, the behavior is different, I can't navigate to the object page of the child entities. I can only fill the fields directly in the table and this is a problem for me because I have a grand child entity and is not possible with this behavior to fill data in my grand child entity...

As you can see, is an editable table, I don't navigate to the object page 'Items'.

How can I change this behavior ?

Thanks

Accepted Solutions (0)

Answers (2)

Answers (2)

MioYasutake
Active Contributor
0 Kudos

Hi luigichiappini,

Please check if the route to the grand child page is included in the manifest.json. If not, you can configure the navigation from page map. Incase that the add button is disabled, refresh the local metadata with service manager.

Regards,

Mio

luigichiappini
Discoverer
0 Kudos

Hi mioyasutake,

I checked the manifest.json and indeed the route to the grandchild page is not included.

I tried to configure navigation from page map but I can't configure it.

Regards,

Luigi.

MioYasutake
Active Contributor

Hi luigichiappini,

Please check your local metadata file and see if the grandchild entity is included. If the entity is missing, refresh the local metadata with service manager.

Regards,

Mio

luigichiappini
Discoverer
0 Kudos

HI mioyasutake,

The problem is solved, thanks for your help.

Regards,


Luigi

WouterLemaire
Active Contributor
0 Kudos

Normally the behaviour should be exactly the same for both. Do you use embedded gateway or hub? In case of hub, eclipse will preview with the ui5 version of backend which might be different from the one you have on frontend server.