cancel
Showing results for 
Search instead for 
Did you mean: 

Multiple Custom UI not working in My Inbox : SCP Workflow in CF

karanbahl
Active Participant
0 Kudos

Hi All,

I have 3 User Tasks in my workflow. 2 User Tasks utilize the common UI which is a custom UI5 App; is not a part of the workflow form functionality. This UI is working fine in the My Inbox application.

The 3rd User Task has a form based custom UI which should get triggered on the basis of some condition, However; this form based UI is not available on the My Inbox app when the respective condition is triggered. However, I can see in the Monitor Workflow Instances app that the user task is available; but it does not show up in the My Inbox App.

Also, There are no errors in the console. Any idea what could be the issue ?

archana.shukla tobias.breyer - Any suggestions guys?

Regards,

Karan

Accepted Solutions (1)

Accepted Solutions (1)

tobias_breyer
Employee
Employee

Hi Karan,

as outlined above, some IDPs have peculiarities about the case of login names. Looking at your screenshot, my guess is that you specify the username with upper case initials. This is not necessarily the way how the login name comes in the access tokens sent to workflow. Please retry e. g. with complete lower case.

If that does not help, your case is not suitable to be discussed here. Please open a support incident.

Please do not forget to specify subaccount ID and region as well as the example workflow instance IDs. Please also specify which IDP you use and what are the settings there, e. g. for shadow user creation.

Regards,

Tobias

karanbahl
Active Participant
0 Kudos

Hi Tobias, Thank you for the useful insight; using email id in all lower cases worked.

Regards,

Karan

Answers (1)

Answers (1)

tobias_breyer
Employee
Employee
0 Kudos

Hi Karan,

if it is not showing up in your inbox, but you can see that it has been created, then check the recipient users/recipient groups in the Monitor Workflow Instances for differences between the tasks.

The following could be reasons:

- You are not listed as a recipient user.

- Your user is not part of any recipient group.

- There is a spelling error for recipient user or group, e. g. case needs to be consistent to IDP spelling.

Best Regards,

Tobias

karanbahl
Active Participant
0 Kudos

Hi Tobias,

I have listed my email id as the recipient and even when I assign my id as the processor in the Monitor Workflow Instances app; I still do not see the task in My Inbox. The form based custom UI; as a part of workflow does not appear. I am unable to troubleshoot as there is no error in console also. Should I raise an incident for this?

Regards,

Karan

tobias_breyer
Employee
Employee
0 Kudos

Hi Karan,

the strategy of workflow to determine whether you are a recipient is quite simple, so I think it is really a mismatch between definition and actual data. Basically everything relevant, besides the new substitution feature, is coming from the authentication tokens, i.e. the user name and the assigned groups.

As it is likely no bug in the software, I don't think an incident will give you much more than my guidance here, but see below.

Have you used "Show Tasks" of an instance from the "Monitor Workflow Instances" and checked other task instances that you can see and which you have claimed in My Inbox? The "processor" value given for those must be one of the configured recipient users.

If it does not work with that one I think the configuration at the task definition is different than what we assume.

Have you checked for differences between the tasks that show up and those which do not, concerning recipient users and groups?

Have you checked that redeployments of changed artifacts were successful?

There are also some pecularities of the IDP behavior that can lead to "missing tasks". But the symptoms do not match here. If you are not consistently logging in with your ID, but differing in the case (sometimes camel case, sometimes lower case), then not all IDPs canonicalize the user name and you only see the tasks that have an exact match between the used login name and the configuration.

With the above, I am somewhat out of ideas. You might then open an incident so that we can go into very technical details and possibly logs.

Regards,

Tobias

karanbahl
Active Participant
0 Kudos

Hi Tobias,

I am sharing the details; please check if these help you to draw some inference:

Below is the Workflow sequece:

1 and 2 User Tasks utilize a common custom SAPUI5 App which is a part of the My Inbox Application; and the 3rd User Task Called Error View has a form based UI; part of the workflow. Screenshots attached as comments since I wasn't able to upload in a single message.

1 and 2 User Tasks are triggered by the same OData service; while 3 is triggered by the error based OData service for capturing the error logs. (wfdef.png)

User Interface for Workflow (errorusertask.png)

Sequence Flow Condition (seqflowcondition)

Monitor Workflow Instances App; the task is available there: (instance.png)

However this is not visible in the My Inbox custom UI. My email id has been configured as recipient for all user tasks.

Please let me know if I can provide some more information on this; and suggest what could be going wrong.

Regards,

Karan

wfdef.png

karanbahl
Active Participant
karanbahl
Active Participant
0 Kudos

Monitor Instance App