cancel
Showing results for 
Search instead for 
Did you mean: 

missing assemblies when installing Crystal Reports (dev version) on Windows 2012 and .NET 4.5.1

Former Member
0 Kudos
78

I have a .NET 4.0 / VS2010 web application that we are in the process of upgrading to .NET 4.5.1 / VS2013 (FYI, we are running VS2013 on a Windows 2013 Server).

I understand that Crystal Reports developer version for Visual Studio does not yet integrate with VS2013 - that's OK.  I at least wanted to be able to install the Crystal Reports 64-bit runtimes and add references to the Crystal Reports assemblies in my VS2013 project.  However, when I install these runtimes onto the 2012 Server, the install appears to complete correctly without any obvious errors  - except that there are no .NET assemblies for Crystal Reports anywhere to be found on the server!

I was hoping that someone could let me know what I am doing wrong - and why the assemblies are not there after the install (as well as how to get them there).  Thanks in advance for your help!

Regards,

Trevor Feldman

Accepted Solutions (1)

Accepted Solutions (1)

former_member183750
Active Contributor
0 Kudos

VA 2013 is not supported at this time. Service Pack 9, ETA March, will support VS 2013.

- Ludek

Senior Support Engineer AGS Product Support, Global Support Center Canada

Follow us on Twitter

Former Member
0 Kudos

What about installing the 64-bit runtimes in Windows 2012 Server to get the .NET assemblies so that I can at least reference them from my 2013 project.  Can I at least do that?  Thanks!

former_member183750
Active Contributor
0 Kudos

Sorry. Would not know. Since it is not supported, I'd never even dream of trying. It's one of those things where supported scenarios keep me busy enough...

- Ludek

Former Member
0 Kudos

What operating systems are supported - is Windows 2012 Server (we are using Standard) supported by the 64-bit run-times?

former_member183750
Active Contributor
0 Kudos

Yes it is. SP 7 or higher.

- Ludek

Former Member
0 Kudos

So then why is the 64-bit installer not installing any .NET assemblies (at least I can't find any) when I run it on WIndows 2012 Server 64-bit?  Is this what happens when you install on Service Pack 6 or lower?

jorge_rocha
Participant
0 Kudos

Hello Travor I already installed the Crystal Reports (CRforVS_redist_install_64bit_13_0_8) in vs2013 (8.1 on windows) and it works perfectly, I have not had any problems. I had problems with the following link (http://scn.sap.com/thread/3476473), but managed to solve ...

Former Member
0 Kudos

How did you solve the problem with the link?  Thanks for your help!

jorge_rocha
Participant
0 Kudos

I did not say I solved the problem with this link, I tried to say that it is possible to do what you want. I do not have this problem, so can not help you.

Answers (0)