cancel
Showing results for 
Search instead for 
Did you mean: 

LMDB <--> SLD Sync

deen_malick
Explorer
0 Kudos
1,151

Hi People,

I have the following problem:

After a system copy where the hostname was changed, I made the post copy activities and updated the SLD-CR-Contents.

Now in SOLMAN_SETUP --> System Preparation --> Set Up LMDB I get the following error:

SAP CR Content version 11.10 in LMDB lower than source 12.4


I found the SAP note 1940068 --> note 1891566 which deal with this problem. Unfortunately the repair job (report RLMDB_SAP_CR_REPAIR_LMDB) also failed with the error

Any idea?


Thanks



Accepted Solutions (0)

Answers (3)

Answers (3)

patelyogesh
Active Contributor
0 Kudos

Hello Deen,

You have to fix your CR content and LMDB data.

In order to fix you can follow document as below

Please let me know if you have any issue fixing it.

Regards,

Yogesh

deen_malick
Explorer
0 Kudos

Hi Yogesh,

I still don't have a solution to my problem.

Executing the report RLMDB_SAP_CR_REPAIR_LMDB to repair the LMDB throws the following error message:

Different CIM versions (target namespace: 1.6.49 / reference namespace: 1.6.50)

SAP CR Content repair aborted due to different models

An idea, how to correct the CIM model of the LMDB?

Regards

Deen

patelyogesh
Active Contributor
0 Kudos

Hey Deep,

You need to fix your SLD first.

Is your SLD working proper? Repair your CR Content in SLD first. Once you have it all fixed there run RLMDB_SAP_CR_REPAIR_LMDB

Make sure your SLD CIM version match to your LMDB once you fix it.

-Yogesh

deen_malick
Explorer
0 Kudos

Thaks Yogesh for your reply.

The SLD works fine: I could not detect any inconsistency in it.

But I now manage to correct the CIM model of the LMDB by ...

1) executing the report RLMDB_SUP_MODEL_PATCH (see SAP note 1677210) with the follwing parameters:

2) I could then execute the report RLMDB_SAP_CR_REPAIR_LMDB from the SAP note 1891566 without the error about different CIM model versions between SLD and LMDB.

3) At the end I could sync the CR contents from SLD to LMDB

Regards

Deen

patelyogesh
Active Contributor
0 Kudos

What if you sync LMDB with SLD full?

-Yogesh

former_member182967
Active Contributor
0 Kudos

Hi Deen,

Check if this thread is helps.

Regards,

Ning

deen_malick
Explorer
0 Kudos

Thank Ning for your reply.

I've already check the note you mentioned. Unfortunately the repir report failed because of different CIM model between LMDB and SLD. I'm also wondering about the temp-namespaces in my SLD:

Regards

Deen

former_member182967
Active Contributor
0 Kudos

Hi Deen,

As you may see the last reply:

Regards,

Ning

deen_malick
Explorer
0 Kudos

Hi Ning,

since I have 53 temp-namespaces I'm not sure which one I should rename to default namespace or it doesn't matter!?

Regards


Deen

giri_ayyagari
Active Participant
0 Kudos

try note 1949792


-Giri

manish_singh13
Active Contributor
0 Kudos

Hi Deen,

You have to make sld/active as default namespace. Do not make any sld/import/temp* as default namespace.

Thanks,

Manish

deen_malick
Explorer
0 Kudos

Hi Manish,

sld/active is already the default namespace. But there are also about 53 addtional temp-namespaces in the SLD. Since I still have problems with the sld/active namespace (not synchronizing with the LMDB) the idea is to rename one of the temp-namesapce to sld/active, actualize it with the actual CIM model and CR contents and look if the synchronization with the LMDB ist performed(?).

I think this were the steps used by Anoop (see thread: SAP CR Content version X.X in LMDB lower than source X.X i) to resolve a similar problem.

Regards


Deen

manish_singh13
Active Contributor
0 Kudos

Hi Deen,

As per your first screenshot sld/active has the updated Model Version 1.6.50 and CIM Classes so I would not suggest to rename any old version temp to active.

Please check the various notes mentioned in the discussion link provided by Ning to identify the root cause of your issue:

1. 1891566 - Repair of LMDB CR Content (What is the output of this report in your system?)

2. 1939864 - Check if SAP CR Content is corrupt in LMDB or SLD (What is the output of this in your system?)

Thanks,

Manish

deen_malick
Explorer
0 Kudos

Hi Manish,

1) the check of the LMDB hash results in

But this seems to be ok to me, since the calculated hash matchs the actual version of the LMDB content (11.10)

2) The check of SLD hash shows the expected hash for CR content 12.4

3) Executing the report RLMDB_SAP_CR_REPAIR_LMDB to repair the LMDB throws the following error message:

Different CIM versions (target namespace: 1.6.49 / reference namespace: 1.6.50)

SAP CR Content repair aborted due to different models

The next question is: How to egalize the LMDB CIM model?

Thanks

Deen

manish_singh13
Active Contributor
0 Kudos

Hi Deen,

These results shows that your LMDB & SLD is not in sync (different hash values). This can be fixed through the "Set Up LMDB".

Please try to deactivate & delete current Connection in this step.

Create again new connection and activate it. It should start sync job between SLD and LMDB. Along with this please remember to check that Ranks of Source & Target Namespace (Advanced option). Source Namespace should always be higher than target. Source Namespace should be "sld/active"

Thanks,

Manish

deen_malick
Explorer
0 Kudos

Hi Manish,

thanks for the idea. But I've already tried your suggestions many times, without success :-(!

Regards

Deen

giri_ayyagari
Active Participant
0 Kudos

Hi Deen Malick

Can i assume you have completed post system refresh tasks? have you updated RZ70, delete and create background job. Please confirm and post LMDB  & RZ70 execution screen shots.

-Giri

deen_malick
Explorer
0 Kudos

Hi Giri,

thanks for you reply.

The system copy was made using R3LOAD (export / import).

RZ70 was updated and the corresponding jobs deleted and recreated:

LMDB shows the following:

Regards

Deen

giri_ayyagari
Active Participant
0 Kudos

My apologies Deen, i did't read log completely(look last 2 lines of screenshot). this issue looks like CR content issue. Ps. update CR Content to latest. let me know how it goes.

i assume you are at CRDelta121604.zip which is 12.4 based on your initial post. try reload again and let me know.

good luck

-Giri

deen_malick
Explorer
0 Kudos

Hi Giri,

reloading the CIM model could be done without error message. But while trying to release the last CR content results in

and the transaction LMDB now shows the following:

Regards

Deen