cancel
Showing results for 
Search instead for 
Did you mean: 

Left Align and Right Align and others in SapScript

Former Member
0 Kudos
4,440

Hello everybody.

I am having a little problem in a SAPSCRIPT.

The problem is that I must align to right and to left some words in the same line and I don't know why this isnt working.

In text elements, I'd write the nexts lines:

/E ITEM_LINE

TS &VBDPA-MATNR&,, &VBDPA-ARKTX(34)&,,

/E ITEM_LINE_PRICE_QUANTITY

&wa_certificado-tdline(9)&,,&vbdpa-charg&,,,,&VBDPA-KWMENG(I10)&,,,, ,,

= &KOMVD-KBETR(10)&,,&v_dto(6)&%,, in the example at top).

What is my problem here? Can anyone tell me something about this?

Thank you very much.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Claudio,

1)Check with the paragraph format that you have created for the fields and Tab Alignment.

2)For the Details to print on the same line use the "=" in the tag column.

For reference refer this wiki.

https://wiki.sdn.sap.com/wiki/display/ABAP/Displayingspecificnumberofrecordsperpage.

Regards,

Sravanthi

Answers (3)

Answers (3)

Former Member
0 Kudos

Well, al last, another guy help me in here, so I didn't check before this thread.

He created one paragraph format for each column, with alignment 0,01 so we can manipulate every word exactly.

thank you all very much for helping.

Former Member
0 Kudos

Well, al last, another guy help me in here, so I didn't check before this thread.

He created one paragraph format for each column, with alignment 0,01 so we can manipulate every word exactly.

thank you all very much for helping.

Former Member
0 Kudos

Hi,

Are you using right alignment on the tabs? If the last tab is defined as 'Right' it will line up the decimal places of the last field on the line.

Regards,

Nick

Former Member
0 Kudos

I have used everything I could.

I use right and left alignement in the TAB section (in paragraph format), I use right and left alignement in the standard section (same section), and text appears always in the same way.

I can't understand why is this happening.

What am I doing wrong? The alignement isn't working correctly here.

Thanks por replying!

Former Member
0 Kudos

Hi,

try placing R for right alignment.

= &KOMVD-KBETR(10R)&,,&v_dto(6R)&%,,<PP>&KOMVD-KWERT(R)&

Former Member
0 Kudos

Hi,

Check if you have set the tab setting for the paragraph format that is being used or not.. Also check if the script is activated or not... sometimes these minor mistakes make difference.

regards

padma

Former Member
0 Kudos

Your post doesn't work for me

&KOMVD-KWERT(11R)&

this field must be Align to the right .

1.000.000

235.989

23.688

1.000.236

-


in sapscript----


I5 &VBDPA-POSNR+3(3)&,,|&VBDPA-MATNR(18)&,,|&VBDPA-ARKTX(20)&,,|

= &VBDPA-KWMENG+14&,,| &ZVARG(5)&,,|&KOMVD-KBETR(11)&,,|

= &KOMVD-KWERT(11R)&,,| &ZTVA(5)&%,,

justification = LEFT

i test justification right but also dosn't work

thanks for help