cancel
Showing results for 
Search instead for 
Did you mean: 

Keyfigure has value in BEx query, but shows zero/0 in Webi

Former Member
0 Kudos

Hi community,

I have the following issue with a Bex query with 2 structures:

in Bex, the budget column shows figures right. but in Webi, it shows zero for certain profit KPIs (calc. keyfigures, CKFs).

only for these KPI cells, it is not a general issue with that budget column!

in the Bex cell editor, I have created cell references for these profit KPI cells, but that should not be relevant.

As SAP cannot connect to our BO Webi via OSS properly, I would like to address you.

anyone had a similar situation or solution?

every hint is appreciated! Many thanks and

best,

Phil

Accepted Solutions (0)

Answers (2)

Answers (2)

IngoH
Active Contributor
0 Kudos

Hi Phil,

I have the following issue with a Bex query with 2 structures:

in Bex, the budget column shows figures right. but in Webi, it shows zero for certain profit KPIs (calc. keyfigures, CKFs).

only for these KPI cells, it is not a general issue with that budget column!

in the Bex cell editor, I have created cell references for these profit KPI cells, but that should not be relevan

>> are you using a BW query with two structures ?

Ingo

Former Member
0 Kudos

Hi Ingo, yes, pls see 2nd line of my question. Thanks, Phil

Edited by: Phil on Jul 6, 2010 3:30 PM

IngoH
Active Contributor
0 Kudos

Hi,

so when you design the Universe you do see each keyfigure as a separate entry ?

you do see the structure as a single dimension object ?

Ingo

Former Member
0 Kudos

Hi Ingo,

exactly.

best,

Phil

IngoH
Active Contributor
0 Kudos

ok - so what exactly is the problem then ?

Ingo

Former Member
0 Kudos

Hi Ingo

I am also currently meeting such a problem.

I have Cubic Meter stored in my cube and my BEx query. Also, in my BEx query, I have a unit conversion to convert Cubic Meter to Cubic Feet.

In WebI, when I pull out both Cubic Meter and Cubic Feet, Cubic meter returns me 0, while cubic feet returns me a figure.

Below are the settings of the BW & BOBJ system:

SAP BW SP6

BOBJ SP2 FP2.3

Hope to hear from you soon.

Thanks!

former_member793810
Active Contributor
0 Kudos

In your universe check the setting of this measure to database delegated and see if values come.

Bashir Awan

Former Member
0 Kudos

Hi Bashir,

all keyfigures in that universe are set to database delegated.

Best,

Phil

former_member793810
Active Contributor
0 Kudos

Hi phil,

If you change them to sum or none do you still get not data?

This is what I can think of right now.

Create a new sample report and see if it behaves the same.

Regards,

Bashir Awan