Showing results for 
Search instead for 
Did you mean: 

java.lang.OutOfMemoryError message sending a big file (14mb)

0 Kudos

Hi everyone.

I've read sdn and sap notes and didn't find a solution.

My problem is that i'm sending a 14mb file via ASYNC RFC. The message is going well from XI to R3, but when i have to get the response from the XI via another RFC, i check in SM58 this message : java.lang.OutOfMemoryError

I have changed in exchangeProfile parameter maxheapsize to 1534m and it doesn't work.

any other solution?


Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Inigo,

Have you looked at this note: 821267

Especially point 14, explains the memory requirements of the file adapter. For your convenience I have copied the contents of this point in this reply.

14. Memory Requirements

    * Q: Which memory requirements does the File Adapter have? Is there a restriction on the maximum file size it can process?

    * A: The maximum file size that can be processed by the File Adapter depends on a number of factors:

          o The most important one is the size of the Java heap, which is shared among all messages processed at a certain point in time. In order to be able to process larger messages without an out of memory error (OOM), it is recommended to increase the size of the available Java heap and/or to reduce the concurrency in the system so that fewer messages are processed in parallel.

          o Another factor negatively influencing the maximum message size in releases up to and including XI 3.0 SP 13 is an enabled charcter set (encoding) conversion if the message type is set to "Text".

          o Using the transport protocol "File Transfer Protocol (FTP)" also uses more memory for processing than the transport protocol "File System (NFS)" (up to and including SP 13).

          o If the Message Protocol "File Content Conversion" is used in a File Sender channel, consider that not only the size of the input file affects the File Adapter's memory usage, but even more the size of the XML resulting from the conversion, which is usually a few factors larger than the original plain text file.

            To reduce the memory consumption in this scenario, consider configuring the setting "Maximum Recordsets per Message" for the sender channel. This will cause the input file to be split into multiple smaller mesages.




Answers (1)

Answers (1)

Active Contributor
0 Kudos


have you tried setting EO_MSG_SIZE_LIMIT parameter?

you can also try increasing:

parameter in the instance profile: ztta/max_memreq_MB