Showing results for 
Search instead for 
Did you mean: 

Infoview on tomcat with WinAD Authentication unable to configure SSO.

Former Member
0 Kudos

Hi, we have recently installed BO XI 3.1 with tomcat as app server and configured infoview with WinAD authentication with Kerbros. Now trying to enable Single Sign On, requirement is to end user login into their machines with domain account should not prompt for user/pwd, we are trying to enable Vintela for sso but its not working, getting tomcat 404 error and tomcat log shows. Appreciate your response.

[DEBUG] Wed Apr 18 12:21:14 BST 2012 jcsi.kerberos: Available KDC found: /IPADDRESS:88

[DEBUG] Wed Apr 18 12:21:14 BST 2012 jcsi.kerberos: Sending message to KDC: /IPADDRESS:88

[DEBUG] Wed Apr 18 12:21:14 BST 2012 jcsi.kerberos: Sending TCP request: /IPADDRESS:88

[DEBUG] Wed Apr 18 12:21:14 BST 2012 jcsi.kerberos:     connected;  sending length and request...

[DEBUG] Wed Apr 18 12:21:14 BST 2012 jcsi.kerberos:     sent request;  reading response length...

[DEBUG] Wed Apr 18 12:21:14 BST 2012 jcsi.kerberos:     read length;  reading 100-byte response...

[DEBUG] Wed Apr 18 12:21:14 BST 2012 jcsi.kerberos: --- got 100-byte response, initial byte = 0x7e

[DEBUG] Wed Apr 18 12:21:14 BST 2012 jcsi.kerberos: Message sent sucessfully to KDC: /IPADDRESS:88

18-04-12 12:21:14:558 - {ERROR} [localhost].[/InfoViewApp] Thread [Thread-1];  Exception starting filter authFilter

com.wedgetail.idm.sso.ConfigException: Configured service principal name could not be found [caused by: GSSException: Failure unspecified at GSS-API level (Mechanism level: Client not found in Kerberos database


    Error code: 6

    Error message: null

    Client name: null

    Client realm: null

    Client time: null

    Server name: krbtgt/UK.CORPORG.NET

    Server realm: UK.CORPORG.NET

    Server time: Wed Apr 18 12:21:14 BST 2012)]

     at com.wedgetail.idm.sso.util.Util.checkAgainstKDC(

     at com.wedgetail.idm.sso.AbstractAuthenticator.initAuthenticator2(

     at com.wedgetail.idm.sso.AbstractAuthenticator.initAuthenticator(

     at com.wedgetail.idm.sso.AuthFilter.init(

     at com.businessobjects.sdk.credential.WrappedResponseAuthFilter.init(

     at org.apache.catalina.core.ApplicationFilterConfig.getFilter(

     at org.apache.catalina.core.ApplicationFilterConfig.setFilterDef(

     at org.apache.catalina.core.ApplicationFilterConfig.<init>(

     at org.apache.catalina.core.StandardContext.filterStart(

     at org.apache.catalina.core.StandardContext.start(

     at org.apache.catalina.core.ContainerBase.addChildInternal(

     at org.apache.catalina.core.ContainerBase.addChild(

     at org.apache.catalina.core.StandardHost.addChild(

     at org.apache.catalina.startup.HostConfig.deployDescriptor(

     at org.apache.catalina.startup.HostConfig.deployDescriptors(

     at org.apache.catalina.startup.HostConfig.deployApps(

     at org.apache.catalina.startup.HostConfig.start(

     at org.apache.catalina.startup.HostConfig.lifecycleEvent(

     at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(

     at org.apache.catalina.core.ContainerBase.start(

     at org.apache.catalina.core.StandardHost.start(

     at org.apache.catalina.core.ContainerBase.start(

     at org.apache.catalina.core.StandardEngine.start(

     at org.apache.catalina.core.StandardService.start(

     at org.apache.catalina.core.StandardServer.start(

     at org.apache.catalina.startup.Catalina.start(

     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

     at sun.reflect.NativeMethodAccessorImpl.invoke(

     at sun.reflect.DelegatingMethodAccessorImpl.invoke(

     at java.lang.reflect.Method.invoke(

     at org.apache.catalina.startup.Bootstrap.start(

     at org.apache.catalina.startup.Bootstrap.main(

Caused by: GSSException: Failure unspecified at GSS-API level (Mechanism level: Client not found in Kerberos database

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

Hi Sebastian, Many thanks for your quick response, i checked the SAP note, i tried to figure out the problem, as per sap note to test princ value.

the service account i created on AD is z-service-boadmin and executed SPN using


setspn -A HTTP/hostname@REALM (eg.

in Web.xml file i i tried both spn for princ parameter and infoview page was simply giving me tomcat 404 error.

As note says to test princ use command kinit.exe BOBJCENTRAL/HostFQDN it was not working, then i tried kinit z-service-boadmin it worked, so the same i tried to use in web.xml as princ, atleast i get the infoview page on the page i see error that generated ticket unable to decrypt there could be different spn name.

Any suggestion on SPN or principle name for service account should be.

0 Kudos


do you get the error message within the InfoView Login Page? If yes please post the Error message.



Former Member
0 Kudos

Hi Seb, Many thanks for your help , issue got resolved, as i told you there was some error with service account SPN entry, i correct it and now SSO is working fine.

0 Kudos


check SAP Note - 1292886