Showing results for 
Search instead for 
Did you mean: 

InfoPackage loading giving IDOC Error: Status 51

Former Member
0 Kudos

Hello Experts,

1) I created a DB view (ZZVIEW05) in the SD area on R3

and it extracts data OK in RSA3.

2) I replicated the DataSource in BW, Created InfoSOurce

activated and created an InfoPackage.

3) Scheduling the InfoPackage is failing with an Error:

Transfer(IDocs and TRFC):Errors Occurred

Request IDOc: APplication document not posted

For the Error, I right Clicked and looked at the IDoc status in the Source System (R3 – where we are getting the data from).

The Idoc with Error has a status of 51 and has the following message:

Any suggestions ?

Thanks, BB


Function module not allowed: ABI_IDOC_DISPATCH

Message no. B1252


The function module ABI_IDOC_DISPATCH and the

application object type which were determined

are not valid for this IDoc.


1. Please check that the process code in the

inbound partner profile is correct.

2. If this is the case, you should check the ALE

inbound methods ALE inbound methods for the

process code and see whether the specified

function module and application object type are


3. If this is also the case, then the function

module and the application object type are not

permitted for the logical message type, message

variant, message function and basis type that

are contained in the IDoc control record. You

should check whether the correct values have

been assigned to these fields in the control

record. If they do have the correct values,

then the assignment to the function module and

the application object type needs to be


Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos


Check this thread



Answers (1)

Answers (1)

Former Member
0 Kudos

Also check your ALE setup like the partner Profiles and see if the correct message types are set and your outbound and inbound parameters.



Former Member
0 Kudos

Hi Dinesh & Sat,

I tried following:

Using WE19.....I was able to manually pump the IDOC that got stuck in ALE inbox on R3 side...then R3 was able service the request and send data to BW.

It seems the correct function module (R3 side) to process an incoming BW data request is RSAP_IDOC_DISPATCHER.

Instead ABI_IDOC_DISPATCHER is being invoked, by default, which is giving the problem (seems to be some kind of authorization issue!).

In WE20, I changed the partner profile to process using RSAP_IDOC_DISPATCHER. BUT somehow it is not being invoked.

I suppose some other setup (table entry) is conflicting with my setup ....

Any clues ?

Thanks, BB

Former Member
0 Kudos


Definitely it effects what suggest is when ever you are doing some changes WE20 i suggest please do it along with BASIS Consultant in your team



Former Member
0 Kudos

Hello All,

I got the same problem, but i maintained all the partner profiles and ports in we20 and we21 resp. Even after that i got the same error. NO IDOCS RECEIVED FROM THE SOURCE SYSTEM.

the Outbound IDOCS was showing green signal, but the Inbound was showing the error.

So some told to recreate the RFC and that went to another situation where i could not even activate the R/3 source system, it was giving error NO BASIC TYPE ....... EXISTS.

After that somehow we succeded with creating SS. Now coming to ur problem....


Try creating SAP REMOTE Cube for the same and see the data in BEx.... i succeded getting the data through this but not with Basic Cubes.


Best Regards....

Sankar Kumar