cancel
Showing results for 
Search instead for 
Did you mean: 

HSR Indexserver replication status shown unknow. XSA is installed on this cluster.

Hana system replication is showing indexserver's Replicaiton mode and Replication status as unknown.

there is not indexserver log in the trace files.

below is the output.

| Database | Host | Port | Service Name | Volume ID | Site ID | Site Name | Secondary | Secondary | Secondary | Secondary | Secondary | Replication | Replication | Replication |
| | | | | | | | Host | Port | Site ID | Site Name | Active Status | Mode | Status | Status Details |
| -------- | ----------- | ----- | ------------ | --------- | ------- | --------- | ----------- | --------- | --------- | --------- | ------------- | ----------- | ----------- | -------------- |
| SYSTEMDB | sdba2 | 30001 | nameserver | 1 | 1 | NODEA | sdbb2 | 30001 | 2 | NODEB | YES | SYNC | ACTIVE | |
| HHA | sdba2 | 30007 | xsengine | 2 | 1 | NODEA | sdbb2 | 30007 | 2 | NODEB | YES | SYNC | ACTIVE | |
| HHA | sdba2 | 30003 | indexserver | 3 | 1 | NODEA | sdbb2 | 30003 | 2 | NODEB | YES | UNKNOWN | UNKNOWN | |

status system replication site "2": UNKNOWN
overall system replication status: UNKNOWN

Local System Replication State
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

mode: PRIMARY
site id: 1
site name: NODEA



can someone help to fix this issue ?

Thanks in Advance

dennispadia
Active Contributor

Hello Sairamgopal,

Have you checked trace files under /usr/sap/SID/HDB00/hostname/trace/DB_HHA folder because tenant database trace file will be under it's folder?

Have you tried to setup system replication again?

It's very difficult to figure out with this little information until and unless there is some direct note which address your concern. There should some hint in trace files which describe why status is unknown.

Did you got change to look into 2481276 - Hana REPLICATION_MODE and REPLICATION_STATUS is UNKNOWN?

Regards,

Dennis.

0 Kudos

Thank you Dennis, it helped I found the indexserver_alert log files under DB_HHA. it says port 40003 already in use

Accepted Solutions (0)

Answers (1)

Answers (1)

dennispadia
Active Contributor

Hello Sairamgopal,

So there you go and I think SAP Note 2712064 - HANA System Replication Error port 4#### already in use will help you.

Also kindly refer some import points for SAP HANA System Replication with Tenant Databases

Regards,

Dennis.

yes I reffered those links , Thank you very much 🙂