cancel
Showing results for 
Search instead for 
Did you mean: 

How to set SAPUI5 version to LTS in Cloud Foundry portal?

alejiandro_sensejl
Active Participant
2,127

Dear experts,

we are currently hosting our Fiori lauchpad on NEO portal. When trying to move to Cloud Foundry, we have regressions in our Fiori apps from latest SAPUI5 1.77 which is used in Cloud Foundry portal service.

How can we set the SAPUI5 version for Cloud Foundry portal service to LTS 1.71? I cannot find a setting in Cloud Foundry website editor (like in Website configuration of NEO portal) or even in SAP Help Guide.

Best regards
Alej

Accepted Solutions (1)

Accepted Solutions (1)

Ivan-Mirisola
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi alejiandro.sensejl,

You can do it on the file CommonDataModel.json by adding the ui5LibraryUrl parameter under the "sap.cloud.portal" session on the "config" settings.

"sap.cloud.portal": { 
		"_version": "1.2.0",
		"config": {
		   "solution":"flp",
		   "fioriVersion":"FIORI2",
		   "theme.id":"sap_belize",
		   "theme.active":["sap_belize","sap_belize_plus","sap_belize_hcb","sap_belize_hcw"],
		   "ui5VersionNumber":"1.77.2",
		   "ui5LibraryUrl" :"https://sapui5.hana.ondemand.com"
		 }
}

NOTE: if you omit the ui5VersionNumber parameter, your application will use the latest version of SAPUI5.

Here is the documentation that shows you all other available site options on that file:

https://help.sap.com/viewer/ad4b9f0b14b0458cad9bd27bf435637d/Cloud/en-US/3466882a5c5148628fa0a8a1a2a...

Best regards,
Ivan

gregorw
Active Contributor
0 Kudos

Hi Ivan,

is there a JSON Schema for the Common Data Model? That would be very helpful and could provide automatic checks and code completion in the App Studio and VS Code.

Best regards
Gregor

former_member194549
Contributor

Hi ivan.mirisola

we are developing a SaaS application that provides apps as content providers.
The portal service is used as a subsciption on subaccount level.

If a UI5 version is specified in the CommonDataModel.json with the parameter ui5VersionNumber, our apps can no longer be launched.

The request for ui5appruntime.html results in an internal server error.

Can you confirm that this setting should also be used when creating a portal via the subscribed service on subaccount level and integrating apps from an content provider?

"sap.cloud.portal": {
    "config": {
        "theme.id": "sap_fiori_3",
        "theme.active": ["sap_fiori_3", "sap_belize_hcb", "sap_belize_hcw"],
        "ui5VersionNumber":"1.71.19",
        "ui5LibraryUrl" :"https://sapui5.hana.ondemand.com"
    }
}

Regards
Simon

Ivan-Mirisola
Product and Topic Expert
Product and Topic Expert

Hi sperstorfer,

According to the documentation, you either use ui5VersionNumber or ui5LibraryUrl. If you use both, only the ui5LibraryUrl is taken into account. In that sense, when you do not state which version to use on ui5LibraryUrl parameter, it should use the latest version. In such cases, you could omit both parameters entirely. If you wish to use a particular ui5 version via URL parameter then the version number could be indicated like so: https://sapui5.hana.ondemand.com/1.68.1

Best regards,
Ivan

Answers (0)