cancel
Showing results for 
Search instead for 
Did you mean: 

How to set a timeout for Analysis for MS Office Sessions

alexander_stettler
Participant
5,446

Hello,

Is there a way to define a timout for BIP sessions created via Analysis for MS Office?

Many thanks in advance!

Best Regards,

Alex

Accepted Solutions (0)

Answers (5)

Answers (5)

stephen_hobbs2
Active Participant

I've been working with SAP and they have said that from Analysis version 2.3.1 there is now a config line in the Ao_app.config file

"After Analysis for Office 2.3 SP1, there is a setting in "'BOESessionRefreshTime" in Analysis for Office setting file %PROGRAMDATA%\Sap\Cof\Ao_app.config: First in the configSections and a second time right after the configSections. This second occurrence is the place where you can change the value. This allows you to choose the time interval for the BOESession refreshes. The time is in seconds. The default value of this setting is "-1". If you enter a negative value (or do not set the setting at all) the old behavior is used (AO takes the session timeout from the BOE). If you enter 0 no BOE session refreshes are done. Please backup this file before making changes."

You also need to add a session.timeout=3600 (or however may seconds) in the Program Files (x86)\SAP BusinessObjects\tomcat\webapps\dswsbobje\WEB-INF\classes\dsws.properties file

I have tested this on a pre-2.3.1 version (2.3.0) and if you put the <BOESessionRefreshTime value="0" /> into the C:\Users\<user>\AppData\Roaming\SAP\Cof\Ao_user_roaming.config file it also works.

Hope the above makes sense?

Regards,

Stephen

0 Kudos

Hello Stephen,

I tried this but it did not work.

I added this tag <BOESessionRefreshTime value="0" /> at the following two places..

1. Ao_app.config

<!--### BoeConfiguration ###-->

<!--default of 'BOESessionRefreshTime': value="0" -->

<BOESessionRefreshTime value="0" />

<!--default of 'BOESystems': value="" -->

2. Ao_user_roaming.config

<TaskPaneWidth value="296" />

<TaskPaneHeight value="696" />

<UsageDataPauseDate value="8/10/2019" />

<BOESessionRefreshTime value="0" />

</configuration>

Do you have any quick check, which needs to be done.

Regards,

Mandanna

former_member523998
Participant

You can use the below macro within any worksheet module. I admit it's tedious to deploy these on each workbook, but it works until this feature is included. You can adjust the parameters in the constants at the top. You could also change to base it off of different sheet events such as change event.

'VBA timeout code for SAP Analysis for Office 
'(hopefully this won't be needed in future versions)
'Insert this code in the one (or more) WORKSHEET modules in a workbook (not a regular module like "Module1")


'Need this variable at the module level to keep track of last click.
    Private timeLIMT As Date


'Set this to False to disable a useful alert message
    Const showWarningOfSignoff As Boolean = True


'Set Timeout limt for inactivity in seconds
    Const secondsFOrTIme As Long = 3600


'You should leave these exact words to alert your users, especially if they are Americans. They will thank you.
    Const messageToDisplay As String = "Boom!! You've been booted! This is a feature your administrator asked for!"


Private Sub Worksheet_SelectionChange(ByVal Target As Range)
'Built by Steven Rider with iTelligencegroup.com    

    If timeLIMT = 0 Then
        'first instance
        timeLIMT = TimeSerial(0, 0, secondsFOrTIme) + Now
    
    ElseIf Now >= TimeSerial(0, 0, secondsFOrTIme) + timeLIMT Then 'too long!
        
    
        Dim gone As Long
        On Error Resume Next 'required to avoid error if already logged off
        gone = Application.Run("SAPLogOff", True)
        On Error GoTo 0 'turn error checking back on.
        
        'optional message after a successful logoff
        If gone = 1 And showWarningOfSignoff Then MsgBox messageToDisplay
        
    Else
        'reset the time limit
        timeLIMT = TimeSerial(0, 0, secondsFOrTIme) + Now
    
    End If

End Sub
'Thanks.

stephen_hobbs2
Active Participant
0 Kudos

Having just started using SSO with Analysis for Office in anger, I too am now finding that I can't see a way to control the timeout for Analysis connections via the BIP! My own answer doesn't work for Analysis but does for CMC and Launchpad.

Any ideas?

Thanks,

Stephen

alexander_stettler
Participant
0 Kudos

Hi Stephen,

For BI Launchpad the settings you've described are working, but the settings does not have any effects to Analysis for MS Office. I've tried also the timeout settings behind the MDAS and DSWS but it seems that all this settings have also no effect to Analysis.

<INSTALLDIR>SAP BusinessObjects Enterprise XI 4.0\java\pjs\services\MDAS\resources\com\businessobjects\multidimensional\services
multidimensional.services.server.session.monitor.idle.timeout=1800000

<INSTALLDIR>\tomcat\webapps\dswsbobje\WEB-INF\classes\dsws.properties
qaaws.session.timeout=600 or rather session.timeout=600

Best Regards,
Alex

stephen_hobbs2
Active Participant
0 Kudos

This might help. SAP Note 1837122

Symptom:
How to increase the session timeout value in BI Launchpad and Central Management Console (CMC)

Resolution:
The default session timeout value for BI Launchpad and CMC is 20 minutes. Follow the below steps to increase the session timeout value as needed.
1. Stop Tomcat.
2. Navigate to the folder <BI 4.0 Install folder>\SAP BusinessObjects\Tomcat6\webapps\BOE\WEB-INF.
3. Open web.xml in Notepad and search for the following tag. <session-config> <session-timeout>20</session-timeout> </session-config>
4. Increase the session-timeout value longer than 20 minutes. For example, this sets the session timeout to 60 minutes. <session-config> <session-timeout>60</session-timeout> </session-config>
5. Start Tomcat.

Regards,

Stephen