Showing results for 
Search instead for 
Did you mean: 

HANA Cloud Foundry trial hdispacedeploy creation failing



I have created a new SCP trial account in Cloud Foundry and created a HANA instance. I have then created new application from template (SAP Cloud Platform Business Application). Build CDS worked fine. Now when building the HANA db, the build fails with:

07:37:14 (HDB) Build command failed : failed to prepare payload on pre build stage: service hdispacedeployc8a4f663-15b9-43f7-bff9-cc65923b5736 is not valid: failed install hdispacedeployc8a4f663-15b9-43f7-bff9-cc65923b5736 application: Failed to execute install command: Failed to execute install command: failed to set delete service : Row not found

As this is a new trial account, it is trying to provision the hdispacedeploy service, however, for some reason it can't. Is this a current issue with the trial acount? Is there any other way to provision the hdispacedeploy application manually?



Active Contributor

Hi Neil,

today I'm facing the same issue with my P-User. When I build the same project with my S-User it's just working like a charm. Have you found any solution?

Best regards

Accepted Solutions (1)

Accepted Solutions (1)


Hey folks,

I got the same error. As soon as I logged out of the Cloud Foundry Space and logged back in, the problem was gone.

Just go to the Preferences perspective and at the Workspace Preferences level, go to Cloud Foundry. Clear the current API Endpoint/Organization/Space configuration, save, re-add them and save again.

Best regards,


Answers (0)