cancel
Showing results for 
Search instead for 
Did you mean: 

FMBB Budget Approval workflow is not triggered

ayyappan_venugopal2
Participant
0 Kudos
1,562

Hi Experts,

I want to activate the standard workflow for Budget Approval in FMBB t-code. I found two standard workflow templates for this WS12300025 and WS12300026 and I activated it. In both workflow templates start event is maintained as 'BUS0050'  'PREPOSTEDDOCCREATED' .

But when I am creating Budget document in FMBB t-code, 'BUS0050' 'POSTEDDOCCREATED' is triggering , so the standard workflow is not triggering.

Then checked in forums, that we should maintain SPRO settings. I maintained the setting in SPRO.(Attachment 1).

After maintained this setting I am facing an error while creating Budget in FMBB t-code. (Attachment 2).

Kindly help me on this is urgent .

Thanks & Regards

Ayyappan.V

Accepted Solutions (0)

Answers (2)

Answers (2)

vigneshwar_reddy
Active Participant
0 Kudos

Hi,

If  the event is triggering then please check event linkage in SWE2 oe SWETYPV.

Regards,

Vignesh

Former Member
0 Kudos

I think you are trying to Post the document but after your configuration it will post the documents only by workflow. Cause of error have no link wth workflow trigger, due to config its not allowing any document to post directly.

Please check the T-code SWEL with Business object BUS0050 and check whether any workflow instance get created. Or else you can execute T-code SWI2_FREQ for today's date (The date on which you have created documents) to check whether any workflow gets triggered or not.

BR,

Prakash

ayyappan_venugopal2
Participant
0 Kudos

Hi Prakash,

Thanks for your immediate reply, I checked in SWEL ,only BUS0050 and 'POSTEDDOCCREATED' event is triggered and no workflow is triggered.

Thanks & Regards

Ayyappan.V

Former Member
0 Kudos

Hi,

Did you check if the event linkage is activated in SWETYPV or SWE2 ?

By default event linkage will be deactivated for standard workflow also. You need to activate it in basic data setting of workflow in SWDD.

Regards,

Ibrahim

Former Member
0 Kudos

What is the error message you are getting in SWEL ? No need to check SWE2. If event linkage not activated it will not get traced.

BR,

Prakash

Former Member
0 Kudos

Prakash,

Even if event linkage is deactivated the event will be shown in trace. It will display message 'No receiver found/entered'.

Regards,

Ibrahim

Former Member
0 Kudos

Ibrahim, The complete statement is:

If event linkage not activated it (Workflow Instance) will not get traced i.e. in T-Code SWI2_FREQ, thats the reason I have suggested to check error message in SWEL .

SWEL will always create entry whether linkage is activated or not, the only thing is trace should be on in T-Code SWELS.  Hope things are clear now.

BR,

Prakash