Showing results for 
Search instead for 
Did you mean: 

Failed to retrieve data from the database

Former Member
0 Kudos

Hello All,

In my stored proc.

I have two decalred parameters as follow:

@AsOfDate varchar (20),

@Entity varchar(8000)= null

at the end of my select statement I have the following code:

WHERE (CPL.Effective_Date = convert (datetime,@AsOfDate) AND (CPD.Src_Intfc_Inst = dbo.udf_wb_GetSourceInstance('STARDIRECT'))

and (CE.Entity_Name = @Entity)

when i run the stored proc in SQL server management I get prompted to enter my parameters it works fine.

when I tried createing my report using (Crystal Report 11.5) the parameter prompter request my parameters but I get error.

failed to retrieve data from the database

detail ado error code ox

@asofdate which was not supplied

Native error [database vendor code:201]

I did create my parameter in crystal is that required ? Since I have it in my stored Proc.

Accepted Solutions (0)

Answers (2)

Answers (2)

0 Kudos

Need more info, Version of CR and SQL Server etc.

Please re-post if this is still an issue to the Data Connectivity - Crystal Reports Forum or purchase a case and have a dedicated support engineer work with you directly

Former Member
0 Kudos

Did you get it working?