Showing results for 
Search instead for 
Did you mean: 

Execute BAPI using SAP Build Process Automation (iRPA) - BAPI exception : Prerequisites are missing

Active Contributor

Hi All

I have created an Automation to execute a BAPI. The Import & Table structures are set. When I execute the Automation, I get the following errors

""label": "BAPI exception : Prerequisites are missing. Please see the help document (https...)"

The error message point to the following link

The pre-req is already installed as per the document

Install Microsoft Visual C++ 2010 Redistributable Package x86,

What else could be missing here, did not find much info in the help documents. I can login to the SAP server using SAP GUI.



Accepted Solutions (0)

Answers (2)

Answers (2)

Product and Topic Expert
Product and Topic Expert

Hi sandip.agarwalla,

There is the possibility is that the VisualC++ version you have installed is more recent than the one the iRPA Agent is prepared to detect. Thus it fails with that message even when you have it installed and it is available to the user that started the Agent on that server.

In that case, I highly recommend you to open a ticket with SAP support for further investigation.

Best regards,

Active Contributor

Hi Ivan

Thanks for your reply. Yes the iRPA agent needed the exact version of the C++ Redistributable, in this case 2010 version.

Fixed the issue after some trial and error. This is the exact combination that worked for me, I have 3.14 version of the Desktop Agent

The first 2 are required for Microsoft Office 365/2016 to run properly ( excel/outlook)

The last 2 are required for the Desktop Agent.

I hope the development team upgrades the dependency of C++ redistributable to the latest version, 2010 is quite old.

Regards, Sandip

Active Contributor
0 Kudos

@sandip.agarwalla thank you !
Is working for me after install the 2010 x86 and 2010 x64 and restart the computer

Active Contributor
0 Kudos

Link to download the
Microsoft Visual C++ 2010
Download Microsoft Visual C++ 2010 Service Pack 1 Redistributable Package MFC Security Update from O...

For me worked after download the x86 and x64 version and restart the computer.