cancel
Showing results for 
Search instead for 
Did you mean: 

Error while sending MATMAS IDOC-MANDATORY SEGMENT MISSING

Former Member
0 Kudos
370

Hi,

Scenario : IDOC - File

There is a scenario already existing, in which MATMAS04 with extension is used, which was working.

Now I removed it, made scenario with MATMAS05 ( no extn, normal MATMAS05)

When I send IDOC, I see error msg in we02, sm58.

No entry in IDX5.

Error message is 26. it says zsegment doesnt exists( which was there in MATMAS04)

Hence, I changed to MATMAS05 from MATMAS04 and removed extn from partner profiles.

I also updated MATMAS05 from MATMAS04 in IDX2.

I still find same error message

I checked both RFC dest. They are working fine.

The exact error message is "Mandatory segment missing"

Where else should I change?

Regards,

Venkat.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

Are you getting this error in XI?

if yes, then did u reimport the idoc and map it in the existing MM?

Regards.

Karna...

Former Member
0 Kudos

Hi,

   Could you explain how to " map it in the existing MM " ?

I face the same situation with

Answers (2)

Answers (2)

Former Member
0 Kudos

HI,

Can you try to resend the old idocs which were passed successfully.

Thanks,

Tuhin

Former Member
0 Kudos

Remove those message types from IDX2, XI will then create them automatically again as needed. It will make a lookup to the sender system and then they will be correct (= up to date).

Not sure if that is the problem, but the first thing I would do.

CSY

Former Member
0 Kudos

in user exit, the developer was checing for message type only (MATMAS)

not if its MATMAS05 or MATMAS04.

Thats y, its expecting zsegment for MATMAS05 also

thanks for ur suggestions.

Venkat.