cancel
Showing results for 
Search instead for 
Did you mean: 

Error when install "SAP Cloud Platform Tools for Java" on Eclipse oxygen/neon

former_member587555
Discoverer
0 Kudos
2,044

On Eclipse oxygen/neon, when I install the "SAP Cloud Platform Tools", the "SAP Cloud Platform Tools for Java" can't be installed and give the following errors.

Cannot complete the install because one or more required items could not be found. Software being installed: SAP Cloud Platform Tools for Java 1.86.0 (com.sap.core.tools.eclipse.server.feature.feature.group 1.86.0) Missing requirement: SAP Cloud Platform server adapter commons 1.85.0 (com.sap.core.tools.eclipse.server.common 1.85.0) requires 'bundle org.eclipse.libra.facet 0.0.0' but it could not be found Cannot satisfy dependency: From: SAP Cloud Platform server adapter 1.85.0 (com.sap.core.tools.eclipse.server.cloud.feature.feature.group 1.85.0) To: com.sap.core.tools.eclipse.server.common [1.85.0] Cannot satisfy dependency: From: SAP Cloud Platform Tools for Java 1.86.0 (com.sap.core.tools.eclipse.server.feature.feature.group 1.86.0) To: com.sap.core.tools.eclipse.server.cloud.feature.feature.group [1.85.0]

Accepted Solutions (0)

Answers (3)

Answers (3)

idan_treivish3
Explorer
0 Kudos
Srdjan
Product and Topic Expert
Product and Topic Expert
0 Kudos

Solved by using Eclipse Oxygen.3a Release (4.7.3a)

Srdjan
Product and Topic Expert
Product and Topic Expert
0 Kudos

The same issue with Eclipse 4.9.0 and sapjvm 8:

Cannot complete the install because one or more required items could not be found. Software being installed:
SAP Cloud Platform Tools for Java 1.86.0 (com.sap.core.tools.eclipse.server.feature.feature.group 1.86.0)
Missing requirement: SAP Cloud Platform server adapter commons 1.85.0 (com.sap.core.tools.eclipse.server.common 1.85.0) requires 'osgi.bundle; org.eclipse.libra.facet 0.0.0' but it could not be found

Can anyone please help?