cancel
Showing results for 
Search instead for 
Did you mean: 

Error when depolying in NWDS

Former Member
0 Kudos
46

Hello, I am a newbie in SAP NWDS. I have a problem in deploying to the server. Previously, I managed to deployed it successfully, but I cant start the browser because of IE problem:( . Hence, I downgrade the IE and try to deploy it again. However, deployment is aborted. And the error stated is "Addtional log information required." What to you mean by *Addtional log information required? In the host file, I add in

127.0.0.1 localhost

172.20.184.236 iwdfvm2160

172.20.184.236 iwdfvm2160.wdf.sap.corp

172.20.184.236 fujitsuSAP01

For the SAP J2EE:

I add in:

Message service host: 172.20.184.236

Message port: 3900

Thanks:)

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Peisze,

1. Goto Window>Preferences>SAP Enterprise Portal and remove all the entries for the Server Information.

2. Now, goto Windows>Preferences>SAP J2EE Engine and enter Message Server Host and Message Server Port (preferably 3901 as suggested) and then say apply.

3. Now, goto Window>Show View>J2EE Engine to open the J2EE Engine Tab in your NWDS. Under it check that all the status as green. If not refresh it by clicking on an icon for it at the top right corner of the J2EE Engine Tab. If the status is all green, then build the project and try deploying it. It will ask for a password. Enter the correct SDM password. If still you have problem let me know along with the complete error message that you get. Otherwise, your configuration for J2EE Engine is incorrect. Get in touch with the Basis team and get the Server Host Name/IP and Server Port for SDM.

Reason for getting red(error) status for J2EE engine could also be there if you have not made an entry for the Host IP and Host Name in the host file, locally.

Regards,

Tushar Sinha

Answers (2)

Answers (2)

junwu
Active Contributor
0 Kudos

hi

by convention the message server port should be 3901.

Best regards,

John

Former Member
0 Kudos

Peisze,

First off, don't place IPs anywhere public.

You mentioned that you have deployed the application successfully before, right? So its not a host name or message server port wrongly placed as parameter.

There are a LOT of possible causes for this problem. Just as it says: it requires more information. So ask BASIS (or if you have access) to look into the log file of the Portal instance to check for the error trace.

Have you tried double-clicking the Error line in the Deploy Output view? It should display a new window.

Also check with the J2EE Engine view if you are actually connected or everything's 'green.'

Regards,

Jan