cancel
Showing results for 
Search instead for 
Did you mean: 

Error staging App"....": BuildpackCompileFailed -staging failed in the buildpack compile phase BAS

0 Kudos

IN BAS: I can't deploy a cloud app since the July sap bas update. my application used the version of node 12.x

package.json

<code>//package 1.json
  "engines": {
    "node": "12.X"
  },
  "dependencies": {
    "@sap/approuter": "^8.6.1",
    "@sap/audit-logging": "^3.2.0",
    "@sap/cds": "^4.6.6",
    "@sap/cds-odata-v2-adapter-proxy": "^1.7.8",
    "@sap/hana-client": "^2.9.23",
    "@sap/html5-repo-mock": "^2.0.1",
    "@sap/xsenv": "^3.1.1",
    "@sap/xssec": "^3.2.2",
    "build": "^0.1.4",
    "cdse": "^1.1.12",
    "cf-nodejs-logging-support": "^6.9.0",
    "express": "^4",
    "http": "0.0.1-security",
    "https": "^1.0.0",
    "jschardet": "^3.0.0",
    "jsrofex": "^1.1.0",
    "node-gyp-build": "^4.2.3",
    "node-pre-gyp": "^0.17.0",
    "nodemailer": "^6.6.3",
    "passport": "^0.4.1",
    "promise": "^8.1.0",
    "request": "^2.88.2",
    "rofexjs": "^1.1.4",
    "utf8": "^3.0.0",
    "uuid": "^9.0.0",
    "ws": "^7.5.3"
  },
  "devDependencies": {
    "@sap/ux-specification": "^1.90.5",
    "sqlite3": "^5.0.2"
  },

// package 2 . json
{
  
  "description": "",
  "scripts": {
    "build": "ui5 build",
    "serve": "ui5 serve -o index.html",
    "start": "node node_modules/@sap/approuter/approuter.js"
  },
  "devDependencies": {
    "@ui5/cli": "^1.14.0",
    "ui5-middleware-simpleproxy": "^0.2.1"
  },
  "ui5": {
    "dependencies": [
      "ui5-middleware-simpleproxy"
    ]
  },
  "dependencies": {
    "@sap/approuter": "^8.6.1",
    "@sap/xsenv": "^3.1.1",
    "@sap/xssec": "^2.2.5",
    "passport": "^0.4.1"
  },
  "engines": {
    "node": "^12.20.0"
  }
}

I have packages because this app generates n services It generates the following warnings when performing the build mta

<code>-npm WARN read-shrinkwrap This version of mpm is compatible with LockfileVersiongl, but package-Lock.json was generated for
LockfileVersiong3. I'LL try to do my best with it!

.npm WARN deprecated Enpmcli/move-file61.1.2: This functionality has been moved to Gnpmcli/fs

-npm WARN notsup Unsupported engine for fsap/ux-specificationgl.102.12: wanted: (["node”:">= 14.16.90 < 15.0.0 || >- 16.1.0 < 17.0.0 |] >=
18.0.0 < 19.0.9","yarn":">=1.22.19 < 2") (current: ("node":"12.22.1","npm":"6.14.12"))

npm WARN notsup Not compatible with your version of node/npm: Gsap/ux-specificationgl. 102.12

npm MARN notsup Unsupported engine for Gsap-ux/fe-fpm-writerg0.17.8: wanted: ["pnpm":">=6.26.1 < 7.0.0 || >-7.1.0","node":">- 14.16.0 <
15.0.0 || >-16.1.0 < 17.0.0 || >-18.0.0 < 19.0.0") (current: ("node":"12.22.1","npm":"6.14.12"))

npm WARN notsup Not compatible with your version of node/npm: Bsap-ux/fe-fpm-writerg0.17.8

npm WARN notsup Unsupported engine for Gsap-ux/vocabularies-typesg0.5.7: wanted: ["pnpm":">-6.26.1","node":">=12.22.5 < 13.0.0 |] >=
14.16.90 < 15.0.0 || >-16.1.0 < 17.0.0") (current: (["node”:"12.22.1","npm":"6.14.12"))

npm WARN notsup Not compatible with your version of node/npm: Esap-ux/vocabuLaries-typesg0.5.7

   

npm WARN deprecated node-pre-gyp0.17.0: Please upgrade to mapbox/node-pre-gyp: the non-scoped node-pre-gyp package is deprecated and
only the Gmapbox scoped package will recieve updates in the future

npm WARN deprecated requestG2.88.2: request has been deprecated, see https: //github.com/request/request/issues/3142

.npm WARN deprecated scmpf1.0.0: scmp v2 uses improved core crypto comparison since Node v6.6.0

npm WARN deprecated uwid63.2.1: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances,
uhrich is known to be problematic. See https://v8.dev/bLog/nath-random for details.

npm WARN deprecated wrench6l.3.9: wrench.js is deprecated! You should check out fs-extra (https://github.com/jprichardson/node-fs-extra)
for any operations you were using wrench for. Thanks for all the usage over the years.

npm WARN deprecated har-validatorg5.1.5: this Library is no Longer supported

npm WARN deprecated uuid63.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances,
uhrich is known to be problematic. See https://v8.dev/bLog/math-random for details.

npm WARN deprecated debugB4.1.1: Debug versions >-3.2.0 <3.2.7 || >-4 <4.3.1 have a Low-severity ReDos regression when used in a Node.js
environment. It is recommended you upgrade to 3.2.7 or 4.3.1. (https: //github.com/visionmedia/debug/issues/797)

npm WARN deprecated w3c-hr-timeg1.0.2: Use your platform's native performance.now() and performance. timeOrigin.

.npm WARN deprecated axiosg0.19.2: Critical security vulnerability fixed in v0.21.1. For more information, see

https: //github. com/axios/axios/pulL/3410

npm WARN deprecated Gsap-cLoud-sdk/coregl.54.2: Version 1 of SAP Cloud SDK is no Longer maintained. Check the upgrade guide for switching
to version 2: https://sap.github.io/cLoud-sdk/docs/js/guides/upgrade-to-version-2.

npm WARN deprecated Gsap-cLoud-sdk/utilG1.54.2: 1.x is no Longer maintained.

npm WARN deprecated Gsap-cLoud-sdk/coreg1.18.1: Version 1 of SAP Cloud SDK is no Longer maintained. Check the upgrade guide for switching
to version 2: https://sap.github.io/cLoud-sdk/docs/js/quides/upgrade-to-version-.
npm WARN deprecated uuid63.3.2: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances,
uhrich is known to be problematic. See https://v8.dev/bLog/nath-random for details.

npm WARN deprecated EnpmcLi/move-fileG1.1.2: This functionality has been moved to GnpmcLi/fs

-npm WARN deprecated Gsap-cLoud-sdk/analytics6l.54.2: 1.x is no Longer maintained.

npm WARN deprecated Esap-cLoud-sdk/analytics61.54.0: 1.x is no Longer maintained.

pm WARN deprecated har-validatora5.1.3: this Library is no Longer supported

but it generates the xx.tar file..

I try to apply the following note: https://me.sap.com/notes/0003124191 , But it does not work

Has anyone had this problem? and how could he solve it?

In the error log I see for example:

<code>led-b074-eeeegas1f37b.hb4-srv.stageAppTaskkt
-riHHERER Fl owable-async-job-executor-thread-5295HH
[Sun Nov 20 17:08:25 UTC 2022] [cds.hana] - Error: Could not establish connection for tenant "anonymous" due to BRRON: authentication fa

<code>1. stageAppTaskkt
B131;1m**ERROR=**I[Om Unable to install node: no match found for "12.20.8 in [14.19.3 14.20.0 16.16.0 16.17.0 18.7.8 18.9.8] (STDOUT, ST
<code>"Error during loading of saas-registry service credentials. saas-registry service is not bound") (STDERR, APP/PROC/WEB)H

ERROR during loading of subscription-manager service credentials. subscription-manager service is not bound") (STDERR, APP/PROC/WEB)?

<br>

Accepted Solutions (0)

Answers (0)