cancel
Showing results for 
Search instead for 
Did you mean: 

Error installing AS ABAP 7.52 SP04, Developer Edition

danny_polak
Explorer
0 Kudos

Dear all,

I am trying to install the AS ABAP 7.52 SP04, Developer Edition.

https://blogs.sap.com/2019/10/01/as-abap-7.52-sp04-developer-edition-concise-installation-guide/

https://www.sap.com/documents/2019/09/32638f18-687d-0010-87a3-c30de2ffd8ff.html
https://abapacademy.com/blog/how-to-install-free-sap-system/


However, I am not successful, first I got this error message:


I fixed this by putting the license in the main folder as well, as described on this post:


https://blogs.sap.com/2016/11/03/linux-for-newbies-installing-opensuse-on-oracle-virtualbox/


But still i cant start the server, you see some parts are gray and not all processes are green.

Also attached you can see my log files, if you need more please let me know.


In the official SAP manual this part inst clear, do i need to specify a server, or is just 8080 enough?



Same for this part, which IP address i should add for the proxy? Or dont change it.

Also there is a mistake in the official SAP manual, the txt and the image they dont match. What is the right line?Because on this link i find it different information:


SAP AS ABAP 7.52 SP04 (Trial) Dev Edition Issues and Lessons | SAP Blogs


Please let me know if you need more, and how i cant get the sever working. Thank you for helping me out!!!

install-2024-01-02-20-20-10.txt

install-2024-01-03-11-01-53.txt

abo
Active Contributor
0 Kudos

please edit the question, putting the images inline with the text to make it easier to read, possibly removing the answer (I suppose you wanted to add the pictures to the question, right?)

danny_polak
Explorer

Is it better now? If not please let me know.

Sandra_Rossi
Active Contributor
0 Kudos

Nice. Just one screenshot missing.

Sandra_Rossi
Active Contributor
0 Kudos
=>sapparam(1c): No Profile used.
=>sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline

I feel that the issue is related to the database license...

See my answer here: https://answers.sap.com/answers/14023703/view.html (although it's VMWare, it's probably valid for VirtualBox too)

danny_polak
Explorer
0 Kudos

sandra.rossi

It is running again, but it now crashes with:

Abort execution because of

Step returns modlib.jslib.caughtException

################################################

Error: sapinst has finished with an error code, please find logs in /tmp/sapinst_instdir

Error code: 20

See the complete log here below:

install-2024-01-03-20-47-03.txt

I used Sudo - i instead of sudo su - But I think it is the same thing right?

My other pending questions are:

1. What do you need to fill in at the proxy settings?

2. What is the correct name for the DNS server?

Sandra_Rossi
Active Contributor
0 Kudos

No idea if there's a difference. I think sudo command is for one command, while sudo su is to make all next commands run as sudo command implicitly.

Proxy is optional (I think it's said in the title of the proxy chapter). Don't enter anything if you don't have a proxy.

Are you sure the procedure says to enter the DNS? I don't think it's needed. I didn't enter a DNS.

danny_polak
Explorer
0 Kudos

I mean not the DNS but this part, now we will map the IP address to the new hostname, which one is the right one?

10.0.2.15 vhcalnplci.dummy.nodomain vhcalnplci

10.0.2.15 vhcalnplci vhcalnplci.dummy.nodomain

10.0.2.15 vhcalnplci vhcalnplci.dummy.nodomain vhcalnplci

Current i am using the last one based on this link:

https://blogs.sap.com/2020/08/04/sap-as-abap-7.52-sp04-trial-dev-edition-issues-and-lessons/

But still i have no idea why it keep crashing, i am running it again now with the sudo su-, but it crashed again, but the log is now longer.

install-2024-01-03-21-56-02.txt

FredericGirod
Active Contributor
0 Kudos

For me you don't even care of solution 1 2 or 3.

What is important is to have a positive return when you do "ping vhcalnplci" .

Check the install shell script, I think there is a command like this ping to check the hostname /etc/hosts setting.

I am used to do a simply: ip_address host_name

Sandra_Rossi
Active Contributor
0 Kudos

all of these have exactly the same meanings:

10.0.2.15 vhcalnplci.dummy.nodomain vhcalnplci

10.0.2.15 vhcalnplci vhcalnplci.dummy.nodomain

10.0.2.15 vhcalnplci vhcalnplci.dummy.nodomain vhcalnplci

On the left you have the IP address, on the right you have the list of all different host names (tab or space separators), the order has no importance.

danny_polak
Explorer
0 Kudos

frdric.girod

The ping works fine, from from the virtual machine terminal.

danny_polak
Explorer
0 Kudos

sandra.rossi

Do you then have any other idea why the installation fails?

Sandra_Rossi
Active Contributor
0 Kudos

So, from your log, your error is still about SAPSYSTEMNAME:

=>sapparam(1c): No Profile used.
=>sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline
################################################
Abort execution because of 
Step returns modlib.jslib.caughtException
################################################

Error code: 20
Error: sapinst has finished with an error code, please find logs in /tmp/sapinst_instdir
You have lots of reasons for this message, look at all the messages about this error in the forum (Sybase license, password you have given is not long enough, etc.)
danny_polak
Explorer
0 Kudos

sandra.rossi

I toke the password from abapacademy.com which is SAPSystem777 so i dont this is the issue, i have put the license in the main folder (what worked for other people) , i have used your guide to replace it.

I can either do again a new clean install and do your guide from the password before the ./install.sh or perhaps you know a option to clear all the files previous installed?

If this also doesnt work, i am really lost...

I deleted everything and installing it again:

I wasnt able to run this command beore:

cp ./License/SYBASE_ASE_TestDrive/SYBASE_ASE_TestDrive.lic /sybase/NPL/SYSAM-2_0/licenses/SYBASE_ASE_TestDrive.lic

So will see, fingers crossed...

danny_polak
Explorer
0 Kudos

sandra.rossi

Fresh new install and the same issue.

install-2024-01-04-15-32-34.txt

Maybe it is because the openSUSE-Leap version?

Which version are you running?

danny_polak
Explorer
0 Kudos

julie.plummer Do you have any idea what the issue could be?

Sandra_Rossi
Active Contributor
0 Kudos

I'm running OpenSUSE 15.3:

danny_polak
Explorer
0 Kudos

I see you run 8 GB memory, and 4 processors.

Can you share your disk sizes with me? how is the 110GB divided?

FredericGirod
Active Contributor

I am little bit lost of all these comments 🙂

- Witch user did you use ? (command: whoami)

- witch schell script did you use ? (command could be echo $0 or check with a ps -p $$)

- Could you get the output of : cat /etc/hostname

Did you check this thread : Issue installing SAP NetWeaver AS ABAP Developer Edition 7.52 SP04 | SAP Community

Sandra_Rossi
Active Contributor
0 Kudos

danny.polak No idea how the 110GB is divided. Just follow the guide, you wouldn't need to ask. Concerning the Sybase license, did you really download the latest license file from sap.com, and did you put it in /sybase/NPL/SYSAM-2_0/licenses/SYBASE_ASE_TestDrive.lic?

frdric.girod The situation is the same as initial, about SAPSYSTEMNAME:

=>sapparam(1c): No Profile used.
=>sapparam: SAPSYSTEMNAME neither in Profile nor in Commandline
################################################
Abort execution because of 
Step returns modlib.jslib.caughtException
################################################

Error code: 20
Error: sapinst has finished with an error code, please find logs in /tmp/sapinst_instdir
danny_polak
Explorer
0 Kudos

I got the licensee from:

As you see see the License is correct

danny_polak
Explorer
0 Kudos

I updated the license as you can see, with your command:

cp ./License/SYBASE_ASE_TestDrive/SYBASE_ASE_TestDrive.lic /sybase/NPL/SYSAM-2_0/licenses/SYBASE_ASE_TestDrive.lic
I also reinstalled everything again, with a password with 8 characters. ################################################Abort execution because of Step returns modlib.jslib.caughtException################################################INFO 2024-01-05 21:09:59.090 (root/sapinst) (startInstallation) [syuxcdir.cpp:147] id=syslib.filesystem.removedDirectory CSyDirectoryImpl::sap_remove(ISyFSErrorHandler * pErrorHandler)Removed directory /root/.sapinst/vhcalnplci/16737.Error: sapinst has finished with an error code, please find logs in /tmp/sapinst_instdir
All logs have been written to the file /media/sf_S4installer/install_2024-01-05_21-02-27.log
Please see readme.html to find out how to get help
install-2024-01-05-21-02-27.txt
danny_polak
Explorer
0 Kudos

What do you mean with this? - witch schell script did you use ? (command could be echo $0 or check with a ps -p $$)

FredericGirod
Active Contributor
0 Kudos

Hi danny.polak in some version of Suse the default shell script is not the good one. You have to install it.

There is Bash, Ksch .......

Accepted Solutions (1)

Accepted Solutions (1)

danny_polak
Explorer

I finally got it working now.

1. I did a clean new install with openSUSE-Leap-15.3-3-DVD-x86_64-Build38.1-Media

2. I used a password similar to Down1oad

3. 10.0.2.15 vhcalnplci.dummy.nodomain vhcalnplci

4. First installed failed and then i used, cp ./License/SYBASE_ASE_TestDrive/SYBASE_ASE_TestDrive.lic /sybase/NPL/SYSAM-2_0/licenses/SYBASE_ASE_TestDrive.lic to move the new lic.

5. Run the install again and then it finally worked!!

Sandra_Rossi
Active Contributor

Thanks, good to know!

What do you think was the problem, what is different from the first install(s)?

julieplummer20
Product and Topic Expert
Product and Topic Expert

Hi sandra.rossi , hi frdric.girod ,

Many thanks for all your support!

danny.polak - good to hear, thanks for letting us know.

Best wishes,

Julie.

Answers (0)