Showing results for 
Search instead for 
Did you mean: 

error in WAS ABAP+JAVA installation

Former Member
0 Kudos

Hi all,

I have a notebook with WAS 6.40 ABAP stack running fine. Now I'm trying to install WAS Java stack (NW04 Sneak Preview SP11) in the same machine, but I always get this error in the 6th step of the installation process:

6th step: MaxDB Database Installation:

<i>ERROR 2005-10-25 15:41:59

CJS-00030 Assertion failed: in function sapdb_param_init(db_name, db_host, sapdb_version, inst_type) { var init_s; if (inst_type == undefined) { init_s = "OLTP"; } else { switch (inst_type) { case "LVC": init_s = "LVC"; break; default: init_s = "OLTP"; break; } } var r_arr = sdb_instance_type(db_name, db_host, init_s, sapdb_version); ASSERT(arguments.callee, r_arr != undefined, "SDB: ERROR EXECUTING PARAM_INIT!"); ASSERT(arguments.callee, r_arr[0] == "true", "SDB: ERROR EXECUTING PARAM_INIT! CHECK THE XCMDOUT.LOG FILE!"); return (r_arr[0] == "true");}SDB: ERROR EXECUTING PARAM_INIT! CHECK THE XCMDOUT.LOG FILE!</i>

I've tried several times. I've tried to start and stop the WAS ABAP and all SAP windows services and I always get an error. Before any installation I uninstall previous incomplete installation and I remove all registry entries.

During the SAPinst previous parameters pages, sapinst ask for "reinstall or reuse the SAP MaxDB Web Manager" (or similar). I've tried both options without success. Which is the correct option?

I need to install EP NW04 in the same machine that WASP WAS ABAP to configure the SLD and run a webdynpro application at the portal.

Can anybody help me?

Best regards.

Accepted Solutions (0)

Answers (2)

Answers (2)

Former Member
0 Kudos

I have the same error. However it could be that mine was caused when the uninstall of MaxDB failed and I had to manually delete the files and clean the registry. I am using Netweaver SP11.

Agustin have you solved the problem?

Message was edited by: Dennis

Former Member
0 Kudos

I've it tried again after uninstalling everything about WAS J2EE (registry included). This is the error now:

Step 4. IGS Installation


WARNING 2005-10-26 10:42:13

Execution of the command "D:\RDBMS_MaxDB_7.5.0_Build_18_NT\NT\I386\SDBINST.EXE '-indep_prog' 'c:\sapdb\programs' '-indep_data' 'c:\sapdb\data' '-depend' 'C:\sapdb\J2E\db' '-profile' 'Server' '-b'" finished with return code 1. Output:

ERROR 2005-10-26 10:42:13

MDB-070020 The database installer reported an error. Some database applications are probably still running. Check the log file sdbinst.log.</i>

I've checked that any services or SAP Proccess was running.

Any ideas?

Thanks in advance.


Former Member
0 Kudos

Agustin I think you probably have the same problem as I had which can be resolved by dropping the J2E database read my install log:

A major problem was that I kept on getting installation error where the message gave no indication on what is actually wrong. This was probably caused by the uninstall failure of another Netweaver installation.

To completely remove the installation manually I had to find and stop all the related services in order to delete the files, then I had to clean up the registry.

A another major problem was that the system still believed that there was a J2E database on the system although all its files were deleted. In order to remove (drop) the database I first had to install MaxDB in order to remove the database with the following statement “dbmcli -d J2E -u control,control db_drop”. Use statement “dbmcli db_enum” to view the databases on your system (go to the folder, probably c:\sapdb, were the SAPDB is installed before executing the command in a dos box).

Let me know if this helped.

Kind Regards,


Message was edited by: Dennis