cancel
Showing results for 
Search instead for 
Did you mean: 

Error in BEx

former_member207019
Participant
0 Kudos

We have a quantity field in BEx, while displaying it - is showing as "1423.33 ERR". When we have checked the quantity field, it has 0unit as a reference unit of measure. But 0unit does not have any mapping in the transformations, so it has no data.

Here my doubt is, when we do not have 0unit data itself, in the report it should not show any unit of measure as "1423.33 ERR" which is not correct. Do we have any option to avoid displaying "ERR" for the quantity field except nodim option.


Accepted Solutions (1)

Accepted Solutions (1)

former_member182599
Active Participant
0 Kudos

Jyotsna,

Its probably because the Key figure doesn't have any Unit mapping from the Source. If you are not getting any units from the source you can define the Key Figure with Fixed UoM rather than assigning 0UNIT if that feasible in your scenario. Or you could always use NODIM() but then you would have to use it in every new query you create.

Regards

-Sid

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi Jyotsna,

Please use NODIM() Bex function to avoid such error.  You've to create one formula and within the formula bring NODIM function with the required keyfigure where you face such issue.  ie., you've to add NODIM(Keyfigure).

You can also keep the constant value for 0UNIT from the transformation by providing required unit(ie., kg/L etc.)

Please check if this works for your.  Please let's know.

Regards,

Antony Jerald.

Loed
Active Contributor
0 Kudos

Hi Jyotsna,

As members above said, you need to use the NODIM function to remove the ERR part..

Regards,

Loed

ccc_ccc
Active Contributor
0 Kudos

Hi Jyotsna,

To solve this problem.

You two options:

  1. Use function NOERR( your quantity key figure)  in BEx designer to avoid ERR
  2. Load data with mapping 0unit like EA, KG , BT etcc.

Thank you,

Nanda