cancel
Showing results for 
Search instead for 
Did you mean: 

ERROR => the connected user (SAPABAP1) does not work with the right user/schema

kathleen_a_sales
Explorer
0 Kudos

Hi,

Im having startup issues in my HANA System/DB and Im getting below errors

*** ERROR => the connected user (SAPABAP1) does not work with the right user/schema [dbhdbsql.cpp 296]

*** ERROR => application has to work with schema SAPBWD (dbs/hdb/schema) [dbhdbsql.cpp 298]

Disconnecting from connection 0 ...

Now I'm disconnected from HDB M ***LOG R19=> ThDbConnect, db_connect ( DB-Connect 000256) [thDatabase.c 87] M in_ThErrHandle: 1

*** ERROR => ThInit: db_connect (step TH_INIT, thRc ERROR-DB-CONNECT_ERROR, action STOP_WP, level 1) [thxxhead.c 2748]

Hope someone can help me. Seems like I'm having some troubles in my SAPABAP1 user/schema. How can I correct this Error?

former_member201054
Contributor
0 Kudos

Hi kathleen.a.sales,

You can update the schema name SAPABAP1 in DEFAULT profile.Then start your system and verify the dispatcher is still gray.

I hope this helps with your issue.

Accepted Solutions (1)

Accepted Solutions (1)

BitanC
Advisor
Advisor
0 Kudos

Hello kathleen.a.sales,

Two things :

1. If you are trying to bring up HANA SYSTEM/DB ( I guess from studio/cockpit), please log in by SYSTEM user and any custom admin user with starting privilege. Please do not try bringing up DB with SAPABAP1 as it the the ABAP schema user.

2. If HANA DB is up and you are not able to bring up respective SAP application running on the top of it, then please modify hdbuserstore with correct key/pwd (probably SAPBWD as per your provided log) and try to bring up the application.

Best Regards,

Bitan

kathleen_a_sales
Explorer
0 Kudos

Hi Bitan, I'll go with your item 2.

Yes my HANA DB is up and Running I just cant startup my SAP Application. Do you have a guide or link or note I can follow how to modify hdbuserstore?

kathleen_a_sales
Explorer
0 Kudos

Hi bitanc,

I have modified the hdbuserstore but unfortunately, I'm now getting R3trans -d error.

I have checked my HANA DB studio, it seems that username SAPBWD user is not existing. I don't know why my system is still looking for that user.

I have also edited below parameters on my DEFAULT profile. Just in case it will fix the issue.

but still I'm getting the same errors above

*** ERROR => the connected user (SAPABAP1) does not work with the right user/schema [dbhdbsql.cpp 296] C *** ERROR => application has to work with schema SAPBWD (dbs/hdb/schema) [dbhdbsql.cpp 298] C Disconnecting from connection 0 ... C Now I'm disconnected from HDB M ***LOG R19=> ThDbConnect, db_connect ( DB-Connect 000256) [thDatabase.c 87] M in_ThErrHandle: 1 M *** ERROR => ThInit: db_connect (step TH_INIT, thRc ERROR-DB-CONNECT_ERROR, action STOP_WP, level 1) [thxxhead.c 2748]

BitanC
Advisor
Advisor
0 Kudos

Hello Kathleen,

Assuming the hdbuserstore is rectified and you are still getting the same error , try having a clean restart of the application (restart the sapstart services as well), should help.

Thanks,

Bitan

Answers (3)

Answers (3)

former_member201054
Contributor
0 Kudos

Hi kathleen.a.sales,

You can update the schema name SAPABAP1 in DEFAULT profile.Then start your system and verify the dispatcher is still gray.I hope this helps with your issue.
former_member201054
Contributor
0 Kudos

Hi kathleen.a.sales,

You can update the schema name SAPABAP1 in DEFAULT profile.Then start your system and verify the dispatcher is still gray.I hope this helps with your issue.
Sriram2009
Active Contributor
0 Kudos

Hi Kathleen.

Is this any disconnection from your SAP system? could you check to refer the following SAP note 2573806

Regards

SS

kathleen_a_sales
Explorer
0 Kudos

Hi S Sriram, I simply cannot fully start the SAP System and my Dispatcher is Gray. Ill visit the SAP Note you've provided. Thanks for the inputs.