cancel
Showing results for 
Search instead for 
Did you mean: 

Enhancement option not shown in Mopz .... Totally confused ):

0 Kudos
82

Dear experts,

I want to upgrade 2 servers:

1. SAP ERP 6.0 -


TO----- SAP ERP 6.0 EHP4 / NW 7.01

2. SAP ERP 6.0 EHP4 / NW 7.01 -


TO----- SAP ERP 6.0 EHP5

To accomplish the above mentioned task i need XML files which are generated by solution manager Maintenance Optimizer. We have Solution Manager 7.0 EHP 1 with SPS28. I have successfully add my systems using SMSY with product ERP 6.0. When i created a maintenance transaction then after selecting the systems (Product ERP 6.0), choosing Calculate Files Automatically - Recommended, then on next screen it is only showing me the option maintenance.

I have read several forums and everybody guide to add system with Product ERP 6.0. I have done the same but i am very very confused why Enhancemnt Option is not appearing. Please help and give your expert opinion in resolving this issue. I am very thankful for your help.

Thanks,

Yasir

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi Yasir

A good point to start would be to check, if your landscape definition is correct for this action. So I would assume, that you first need to upgrade your Solution Manager's SLD to latest CIM-Model and Content Version and install Solution Manager Landscaep Verification Tool.

Hope, this helps you any further.

Regards, Michael

Answers (8)

Answers (8)

0 Kudos

Thanks micheal and diego. That problem was due to old SLD component repository. When i updated the SLD with latest delta upgrades the option enhancement package installation is now visible and is working perfect. i am rewarding points to both of you and marking my thread answered.

Thanks,

Yasir

0 Kudos

I have also tested the RFC SAP-OSS with authorization it is ok and S-user associated with installation number is present.

0 Kudos

I have checked using t-code AISUSER, the user has been assigned to S-user.

nicholas_chang
Active Contributor
0 Kudos

I means the SAP-OSS RFC connection in SM59. Forget this if you've set correctly.

0 Kudos

The user we have provided to SAP has already assigned to S-User in our solution manager.

Jansi: I read the sap note and match everything present in the PDF document. My product is ERP 6.0 and i have matched all things they are similar to what i have defined in my solution manager. I am very much confused and received no reply from SAP as well. I am waiting for the reply from SAP.

Thanks,

Yasir

nicholas_chang
Active Contributor
0 Kudos

Hi,

How about the S-USER ID user in SAP-OSS, is it the correct S-USER belong to the customer number for that system?

We'd a issue exactly like yours where all product assignments were set correctly, all notes applied but nothing appear. We found out there was a transport where a new customer no was added and SAP-OSS connection is changed for S-USER ID.

Thanks,

Nicholas Chang

Former Member
0 Kudos

Hi,

Normally this issue happened with the wrong product definition, make sure your product defined as ERP.

and check this wiki http://wiki.sdn.sap.com/wiki/display/SM/TroubleshootingofMaintenance+Optimizer under the section as "Enhancement Package install option does not appear" and check the note 1322259.

Thanks,

Jansi

0 Kudos

Diego,

Thanks for your reply. I have read the SAP Note and found that in our system CR Content version is 2.0, i have downloaded all the things as mentioned in the SAP Note.

We have also raise an OSS to SAP and they are currently looking after the problem. Once i got reply from them i will update our CR repository of Solution Manager.

Thanks,

Yasir

nicholas_chang
Active Contributor
0 Kudos

Hi,

At the meantime, could you please check is it multiple cust.no support in your solman. if yes, ensure the S-USER use in sap-oss is belong to the correct cust.no, and also AISUSER.

Thanks,

Nicholas Chang

0 Kudos

Experts,

Thanks a lot for your reply.

Sunny: I have selected ERP 6.0 in logical component.

Micheal: Can you guide me for solution manager SLD ugrade and other activities. I have successfully completed the solution manager initial and basic settings. all completed successfully.

Thanks,

Yasir

Former Member
0 Kudos

Hello Yasir,

Check this note: Note 669669 - Updating the SAP Component Repository in the SLD

Cheers,

Diego.

sunny_pahuja2
Active Contributor
0 Kudos

Hi,

What is the product version that you have selected for the logical system ? Please make sure that product version for logical system should also be ERP 6.0.

Thanks

Sunny