cancel
Showing results for 
Search instead for 
Did you mean: 

DTR tool replicates with wrong encoding

Former Member
0 Kudos
100

Hi all!

I am trying to migrate an old NWDI (based on 7.00) to a new one (7.40). To get the existing tracks to the new NWDI I create the tracks at the new NWDI and copy the sources with the version history according to this link

http://help.sap.com/saphelp_nw70/helpdata/en/46/5d032c1e661cbee10000000a11466f/frameset.htm

I have migrated a lots of tracks successfully but now there is a track language specific signs (Umlaute) at the naming of the activities. Since I was not aware of that I just started the migration as always.

But when I had a look at the sources I got some strange behaviours:

- Of course the names of the activities were not correctly encoded

- At the new repository all activities that delete folders are visible at the activities list but were not executed. The folders are still there but empty.

- At the new repository there are some strange other activities, always named "equals_relation_creation_for_(...)"

Now I have found out that file.encoding was configured wrongly at my Java VM. For a new try I need to remove the activities from the database.

What I already tried:

-  Delete the repositories and recreate these by removing the SC from the track, delete the repositories, re-adding the SC and restart the replication process.

- Delete the repositories and tried to delete the activities from the database with the gc-command at the DTR tool. Unfortunately there are so many activities that have to be removed that the database says "too many cursors". I didnt find any way around this problem.

- During the replication process there is this "-r" trigger at the replicate-command to resume a replication. I just removed the "-r" trigger but this did not work.

Is there anyway to remove the activities one by one from the database (I would write script then)? The "bad" signs are not the worst problem but the existing empty folders. I hope that the other sources are correct.

Accepted Solutions (0)

Answers (1)

Answers (1)

Soumya
Active Participant
0 Kudos

Hi Richard,

I am not sure if you can remove the activities only but if you go into DTR as Web Folder you can delete objects. To delete any folder structure you have to take the inside out approach, i.e. delete all the contents of a folder in a certain level then only you can delete the folder.

But first let a expert guide you with a better solution

Thanks