cancel
Showing results for 
Search instead for 
Did you mean: 

DTP Problem

Former Member
0 Kudos
58

Hi SAP Gurus,

I have a problem with the DTP.

I am trying to load  0SD_C05 cube with the data source 2LIS_11_VAHDR.

The problem is, after executing the DTP it says some errors like :

1. errors during processing

2. error while updating the target.

I am not sure about the field mappings. I just mapped some fields to the info objects with my knowledge.

And, I want to know that, these standard content info cubes are automatically mapped to the fields or is that to be done manually.

lastly, I am not sure about the Business content activation is done properly on not ?

How to check whether any Info Cube is activated or not from the BI content.

I think I can see those cubes like 0SD_C03, 0SD_C05 are there in the info provider menu in the DWH screen.

Please help me guys,

and sorry If my questions were not that clear as I am doing my first project trying to learn from the scratch .

Hope to get a reply soon.

thanks and regards,

KKP.

Accepted Solutions (1)

Accepted Solutions (1)

Former Member
0 Kudos

Hi,

The error may be due to some mapping error in the transformation level.

0SD_C05 is a standard infocube activated from the business content. While doing so, the transformation mapping will also be activated along with it. If you want to check whether the flow for this cube is installed and activated properly then in Tcode RSA1 under 'BI Content' select the 'Grouping' as 'In Data Flow Afterwards' and 'Collection Mode' as 'Collect Automatically'. Now drag and drop the inforcube from the metadata repository to the right hand side window. When you drill down the cube, the infoobjects, DTP,TRXN,Datasource,IP will be displayed. If these are active then, there will be green status besides them under the acive version.

Regards,

A.Rohini

Former Member
0 Kudos

Hi,

Thanks for the reply Rohini

I have checked the cube in the same way you just told, but I can see only Info area, query element and info objects in the drill down menu of the info cube.

Is that really mean the cube is not installed properly ???

I selected the grouping function as in data flow afterwards but later, again checked with in data flow before and after then update rules are added additionally.

so in the both grouping options I cannot see the DTp's, IP's, TRXN's Datasource's .

Is that mean the infocube is not properly installed ??

if yes can I do the installation again..

please reply me asap.

thanks and regards,

karun.

Former Member
0 Kudos

hello sunny,

dtp and info packages will not cum in the structure.We have 2 create our awn DTPs n IPs once our structre is ready.

While installation under BUSINESS CONTENT tab:

By taking Display mode as "list", u will cum to knw wat exactly u want to install. tick the required  and install.

u can take this cube as object type and set Grouping as "data flow before". Besides this, as mentioned above, take Display mode as "List".

u will have:

info area

application

info objects

info cube

transformations

routines

data source replica

dso(if any)  etc........

u can tick mark the required areas.

But b4 doing all above, u shud have replicated the reqd. data srce for sure on BI side.

thanks,

heena

Former Member
0 Kudos

Hi,

You have mentioned that the Update Rules are visible in the flow, then it is a 3.5 flow. So you will not have DTP or TRXN in that. You will have Communication structure and Update rules instead of transformation.

Regards,

A.Rohini

Answers (3)

Answers (3)

Former Member
0 Kudos

Hi,

I just checked every thing with the DTP, the errors are:

1. I can map the characteristics with relevant fields but there are not relevant fields for the keyfigures

     should I need to write a routine here ????

2. secondly, There was some data in the cube from the char's but KY's data was missing. I know this        is co of the mapping error but I don't exactly know what to do here ???

3. After activating the C05 cube from the BC there are some transformation which came  automatically after the installation but what I don't understand here is when I check the transfer str n comm str in the IS some of the rules are existed already and some don't. why ??

Hope I was clear if not Plz lemme know and kindly reply me asap.

Thanks,

Sunny.

former_member188080
Active Contributor
0 Kudos

Hi Sunny,

1. In case of standard field search you can do it through RSOSFIELDSMAP table..just put the R/3 field and u can see the relevant Infoobject in SAP BW ..

2. This looks like data issue..u might not get in Production may be..you need to check whether all the routines,fields,transformations are active..if not youy make it active manually and activate them RSDG_TRFN_ACTIVATE or manual activations

Reactivate the standard objects if required RSDG_DSO_ACTIVATE etc

..

3. mAY BE try installing those transfer rules,communication selectively..In BI7 again IS not required...but for this old LIS flow it might be required..

just see all the rules,IS,routines are available actively for data load to happen successfully..I think DTP load might or might not require and only Infopacakge have option to load in PSA and then to data target..

Thanks and regards

Kiran

Former Member
0 Kudos

Hi,

Check Transformation/DTP are fine

Check Filters and any erroneous records in error stack

Check any End/Expert Routines are there

Check corresponding Master Data has been loaded or not

Reagards,

Aravind.

Former Member
0 Kudos

hello,

In "Modelling" under infoproviders tab, if u see the cubes which u have installed, it means dey r installed.

And also, to have the whole flow ready u have to install its respective transformations, and the rest flow from Business Content.

thanks,

heena.

Former Member
0 Kudos

Thanks for the reply Heena,

I got the logic but Installing the cube itself install all the related transformations, update rules etc right ???

If it's not how to install the respective transformations which are related to the cube ??

N please reply me about the DTP error.

Thanks,

KKP