cancel
Showing results for 
Search instead for 
Did you mean: 

Data not updating for some fields in ADSO

former_member184624
Participant
0 Kudos
327

Hi BW Experts

We have data flow where data gets loaded from Infosource to Infsource and then to ADSO ,between the 2 infosources we have a end routine logic. When a FULL load DTP getting executed via PC one of the field(ORGMD) is returning blank value. whenever i tried to debug with selected document ID & line items i am able to see expected output value for the ORGMD field in result package while debugging. But while checking the data in ADSO, some of the master data attribute values are not updating in the ADSO. Can you please advise, why this is happening.

Sample code in TRFN -

READ TABLE LT_ORG_DATA INTO LS_ORG_DATA

WITH KEY /BIC/WC_ORGMD = LS_CUSTOMER-/BIC/WC_ORGID

DISTR_CHAN = LS_CUSTOMER-DISTR_CHAN

SALESORG = LS_CUSTOMER-SALESORG

DIVISION = LS_CUSTOMER-DIVISION

BINARY SEARCH.

IF SY-SUBRC EQ 0.

<FS_WC_ORGMD> = LS_ORG_DATA-/BIC/WC_ORGMD.

ENDIF.

ENDIF.

ENDIF.

Accepted Solutions (1)

Accepted Solutions (1)

appel_solar_dk
Active Participant
0 Kudos

Hi Jalina

You say that your routine is correct. So look at

a) mapping in the transformations

b) target fields in the end routine:

Before you enter your end-routine you must select all your target fields. In the picture above SALESORGA could be filled in the end-routine, but it will not get updated in the DSO as it's not in the target fields.

regards

Kristian

Answers (0)