cancel
Showing results for 
Search instead for 
Did you mean: 

Custom MVC BSP called within Netweaver2004S/Portal has initial View

alexander_schuchman
Participant
0 Kudos
72

I have created an MVC BSP and when running this from SE80 or directly using the URL for the ICM server(CRM 5.0 box with WAS running on it), the application works fine. The DO_HANDLE_EVENT method is able to retrieve information about the view. Everything is working great.

I have the "Stateful" and "Supports Portal Integration" Flags checked.

Then I create a BSP IView and a CRM BSP IView in the Netweaver 2004S Portal(EP7) and neither of these is working properly. (Wasn't portal integration suppossed to be easy) When I debug, within the DO_HANDLE_EVENT, the view ALWAYS comes back as "INITIAL" therefore I can't read any of the user's input that was submitted via the BSP. I even tried specifying the "Domain Relaxing" url param, but that didn't help.

I'm sure this is due to a settings within the either the IView or the BSP. The problem is that I can't figure out which one is the problem.

Any help would be appreciated.

-Alex

Accepted Solutions (0)

Answers (1)

Answers (1)

Former Member
0 Kudos

Iam not sure about the 2004S i guess it would the same as 2004. Just a long short..

did you use the sys-sapcmd paramter with nocookie value?

alexander_schuchman
Participant
0 Kudos

You are right, netweaver and netweaver 2004s are about the same.

Unfortunately I have tested with and without the sys-sapcmd=nocookie additional application parameter and neither solves the problem.

Something in the portal session management frame of the window is causing the problem.