Showing results for 
Search instead for 
Did you mean: 

CTC DI all-in-one fails at Step: Upload Default ACL Settings

Former Member
0 Kudos


i need your help.

I tried to install a NWDI on a SolMan (Rel. NW7.01 SP06).

I deployed the necessary SCAs (DI_CBS, DI_CMS and DI_DTR =7.01SP6).

At the next point I'd like to use the wizard for the initial setup (DI all-in-one) and here are my problem.

At the step "Upload Default ACL Settings" it aborts with the error: Not a valid URL: Unexpected character found [':' at position 7]

Here an an excerpt from the log:


Exception Class:

Exception Message: Not a valid URL: Unexpected character found [':' at position 7]

Stack Trace Not a valid URL: Unexpected character found [':' at position 7]



at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(

at sun.reflect.DelegatingMethodAccessorImpl.invoke(


Caused by: Not a valid URL: Unexpected character found [':' at position 7]






I checked the default Users. The NWDI_ADM, NWDI_DEV and NWDI_CMS (The NWDI_CMS was manuel created) exists and have the expective roles/groups and actions (e.g. NWDI_ADM = Group NWDI.Administrator = Role NWDI.Administrator + Action LcrInstanceWriterAll)

I checked the log/protocol and the strange argument there is dtrUrl : http://:/dtr.

I think the wizard is missing the right hostname an port for the as java. I tried to execute the Wizard with FQDN, simple hostname, localhost and edited also the host-file (like in other threads proposed).

The check of the SLD-Connection in the SLD-DataSupplier in the VA are OK (the http-settings and CIMClient Test works fine).

I spent a lot of time at the VA and configtool to finde the possible key with the missing value for the host an port, However with no success.

So now im here and hope some of you can give me an advice.

Best regards


Edited by: Denis Stricker on Jan 6, 2012 1:48 PM

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

Hello Denis

I have checked the attached error together with our expert for the DI

configuration wizard and found that the problem is most liked caused

by some variables that are not properly set by the underlying

framework (CTC framework) due to problems with the data bindings.

To investigate the problem in more details it is important for us to

know how the engine was being setup. Can you please let us know if you

directly installed the engine or if you upgraded an existing

engine? In case of an upgrade can you please tell us

which SP had the engine before the upgrade?

So if you upgraded from an earlier SP this might explain

your problem and we would directly know in which area to look.

Unfortunately we cannot offer automatic configuration

after an upgrade case (see our central CTC note: 923359) exactly for

such reasons (besides of that CTC don't know the state after the

upgrade). Configstore does not offer to add new parameters only to


As workaound you can try to run DI template and everytime where it

stops, do the step manually and skip the not working step.



Former Member
0 Kudos

Dear Kenny,

thanks for your reply,

As addition i opened an OSS-Call and they told me the same reason.

In our case the "update" of the SolMan (7.0SP16) to a newer release (NW7.01SP06) is the reason why the CTC failed in some steps.

may be it is interessting for other how we done the manuel steps.

I used the SAP Help:

and the guide: How Tou2026setup NWDI Permissions and Roles (

thanks and kind regards,

Denis Stricker

Answers (0)