cancel
Showing results for 
Search instead for 
Did you mean: 

CRVS2010 - Assembly Version 13 with Vs 2017 and .NET 4.7

Former Member
0 Kudos

Hi, We are planning to upgrade .net framework of our web application from that uses crystal reports CRVS2010 - 13.0.2000, for reporting purpose.

Application runs with .NET 3.5 SP1

VS 2010 is being used for development.

Application is hosted in Windows Server 2012 R2.

We are planning to upgrade the .NET Framework of application to .NET 4.7 & use VS 2017 for development.

Please let us know if this is compatible with CR 13 (CRVS2010-Assembly Version 13).

If not, suggest which version of CR could be used.

Also, when could we expect SP21 to be released.

Regards,

Sharath Molagavalli

Accepted Solutions (1)

Accepted Solutions (1)

0 Kudos

SP 22 and above now supports VS 2017

Answers (1)

Answers (1)

DellSC
Active Contributor
0 Kudos

.NET 4.7 and VS 2017 are not yet supported in the SDK. .NET 4.6 is supported in Service Pack 15 and newer (it's currently on SP 20). I expect that support for .NET 4.7 and VS 2017 will be available with SP21, although I'm not absolutely certain.

-Dell

0 Kudos

I've been using SP20 with VS 2017 / .net 4.6 and it seems to be working ok (to a point, I do have some issues with it, but don't think that's to do with VS2017 - I've recently opened a topic here regarding my issue - Unspecified Error).

I've read that SP21 is due out August / September time.

DellSC
Active Contributor
0 Kudos

Yes, there are some posts here about how to use it with VS 2017, but it's not fully integrated yet. The full integration is supposed to be in SP21.

-Dell