cancel
Showing results for 
Search instead for 
Did you mean: 

Could not connect from Web IDE Full Stack to Cloud Foundry trial

former_member184876
Active Participant

Hi Gurus,

I could not connect form SAP Cloud Platform Web IDe full stack to Cloud Foundry.

My Cloud Foundry trial is active in Europe (Frankfurt).

Organization and Space are created when started the trial.

I could access them form CF CLI.

But when i try to assign cloud foundry details for my project in Web IDE, i am getting below error.

Could not retrieve list of organizations. Please check CF API endpoint.

Thank you in advance,

Venu

former_member184876
Active Participant
0 Kudos

Hi Friends,

any help on this?

Thank you in advance,

Venu

Accepted Solutions (1)

Accepted Solutions (1)

keren_rotenberg
Product and Topic Expert
Product and Topic Expert
0 Kudos

Hi All,

Do you still have these issues?

thanks,

Keren

former_member184876
Active Participant
0 Kudos

The connection is working now.

Thank you..

bassuino
Explorer
0 Kudos

Hello,

Did you guys find any resolution for this issue?

API Endpoint is working. The only difference is my account is not a trial account. When trying to connect, I receive an 401 - not authorized but this is the ajax call. If I include a non-existent endpoint URL, I receive the exact same message when recording network from Chrome.

Cheers,

Fernando

mariusobert
Developer Advocate
Developer Advocate

Are you on the project settings page as Venu was on his screenshot?

If so, can you try to connect to the CF endpoint by clicking on the gear on the left-hand side and try it from this page?

bassuino
Explorer
0 Kudos

Hello Marius,

Thanks for your response.

Yes, I am on the same screen.

cloud-foundry.png

After inserting the API endpoint, another screen pops up to insert my credentials. I insert my credentials and press the Ok button and nothing happens (no organization or spaces are loaded). I tried to insert the wrong credentials to see what was going to happen and the screen keeps popping until I insert the correct one.

The space is created and started.

Thank you,

Fernando

mariusobert
Developer Advocate
Developer Advocate
0 Kudos

Hi Fernando,

this is for sure not the expected behavior. Can you contact open an incident for this? You can create one by clicking on you name on the top right corner (in the Cloud Platform Cockput) -> Contact us -> Technical Assistance


Regards,

Marius

Answers (6)

Answers (6)

former_member206574
Active Participant
0 Kudos

Hi All,

It is an intermittent issue of WebIDE and Cloud Foundry in trial accounts. WebIDE team resolved these issues as early as possible. We can't do much here. Closing this question.

former_member206574
Active Participant
0 Kudos

Hi all,

Is there any resolution for the above issue. I too facing the same issue from last week.

Regards,

Venu

0 Kudos

Hello for me it's same here, I'm not able to connect to CF (I deleted my previous CF and create a new one also). I'm on a trial account and everything looks fine.


Dan.

Former Member
0 Kudos

Hi Team,

Even Im facing the same issue.

I could log in to Cloud Foundary, however from WebIDE it is giving below error.

GET https://webidecp-XXXXX.dispatcher.hanatrial.ondemand.com/di/cf-ops/orgs-spaces?landscape=https://api... 401 (Unauthorized)

Regards,

Gopikrishna.

stephen_kringas
Active Participant
0 Kudos

Hi Gopikrishna,

Did you manage to solve this? I'm currently experiencing the same error.


Stephen

asaf_bruner
Advisor
Advisor
0 Kudos

Hi Venu,

Do you still experience connection issues?

Best Regards,

Asaf

mariusobert
Developer Advocate
Developer Advocate
0 Kudos

Hi Venu,

I have seen this issue before. Unfortunately, I don't know how to "fix" it, but I know you can work around it by deleting your CF subaccount and creating a new one (with the same name).

This would result in losing all your apps/services. Can you try to do that or do you need to keep your data?

Regards,

Marius

former_member184876
Active Participant
0 Kudos

Hi Marius,

I deleted the CF sub account and recreated it with same details.

In my case i am still not able to access CF form Web IDe.

Best Regards,

Venu

mariusobert
Developer Advocate
Developer Advocate
0 Kudos

That's strange. Is it the same issue as before or another one?

0 Kudos

Hi Marius,

Im facing the same issue. I have tried all the ways but no luck.

Regards,

Gopi.

jonaswang
Advisor
Advisor
0 Kudos

Hi Marius,

Any updates on this? I deleted my CF subaccount and recreated one. But I am still not able to connect CF from web ide.

former_member184876
Active Participant

Hi Marius,

It's was the same error. My CF trial account was in Europe-Frankfurt. Now when i created a different CF account in other region (US region), it worked. But strange it did not work for the account in Europe-Frankfurt.

Thank you,

Venu