cancel
Showing results for 
Search instead for 
Did you mean: 

com.sap.engine.frame.core.load.SAPNoClassDefFoundError

Former Member
0 Kudos
64

Hi all,

I have a WAR which runs quite well under Tomcat. Now I want to move it onto SAP NW AS. So I transform this war into the war with SAP NWDS.

But as I run my application I get error:

Application error occurred during request processing.

Details: com.sap.engine.frame.core.load.SAPNoClassDefFoundError: org/w3c/dom/ranges/DocumentRange

Exception id: [000C293497420078000000520000086C0004413BE19DA513]

Then I insert the rt.jar from jdk 1.5_09 since the class "org/w3c/dom/ranges/DocumentRange" is inside "rt.jar". But I got another error:

Application error occurred during request processing.

Details: java.lang.UnsupportedClassVersionError: org/w3c/dom/ranges/DocumentRange (Unsupported major.minor version 49.0)

Exception id: [000C29349742006B000000840000086C0004413BDBEBC974]

Which version should I use? And where can I find it?

Accepted Solutions (1)

Accepted Solutions (1)

Vlado
Advisor
Advisor
0 Kudos

Hi Thomas,

As Sameer noted, SAP NW 04 and 7.0 (aka 04s) run with JDK 1.4.

You should be using the JAXP API, not specific impl class(es) from JDK 1.5, to avoid such troubles.

HTH!

-- Vladimir

Former Member
0 Kudos

Thanks.

Answers (1)

Answers (1)

Former Member
0 Kudos

Moin Thomas,

Which version of NW do you have? 2004s needs a JDK version 1.4.2_09 to 1.4.2_11. The runtime jar from 1.5 will not work at all. Any Java version higher than 1.4.2_11 is actually not supported.

Bye,

Sameer

Former Member
0 Kudos

You are right.

I change to using the java 1.4 and it works.