Showing results for 
Search instead for 
Did you mean: 

Check-in starts after minutes

0 Kudos


we have a real performance issue with our system, especially during check-in.

I have observed, over 90% of the time needed to check-in a model into the repository is caused by some "pre-preparations" PD Client is doing. I don't know what he is doing during that time, but we can see it in the Task Manager. There we can observe, how the memory consumption of pdshell16.exe is growing, and we see, that pdshell16.exe consumes 50% of the CPU... and this during an hour (or ever more) for a check-in of a 60MB big PDM (Oracle11g and Oracle12c) model. The longest waitis can be observed, when we are checking-in a completely new model, or when merging changes.

On the server itself, no new *.prx file is created during that time,there is also no load on the DB (SQL Anywhere 17) ...

After that one hour, PD is starting with the "real" check-in. Here, we can see it in the SQL Anywhere Profiler. But this takes only maybe 5% of the allover time needed for the whole check-in process.

What is the problem? What is PD Client doing all the time with the model? Did anyone faced such issue?

We have already:

- checked the model for consistency, activeteed the internal checks

- created default empty diagrams

- reorganized object on diagrams, to eliminate overlaps

- generated a new model

- saved the model as .bin instead of .xml

- installed the proxy on the same server, where the DB is installed

- activeted local cache in PD client, and set it to 1GB

- changed the logfile directory in the Proxy Server, to store the logfiles on a different disk, that the DB files, to avoid IO issues

- I have tried also with Pdlegacyshell16.exe to eliminate .NET issues

We are running on 16.6 SP01 PL01, but we have observed the same issues within 16.6 SP05 PL01.

The DBMS we tried with are MS SQL Server 2014 and SQL Anywhere. It's somehow independent from the DBMS we are using for the Repository.

The local workstation is an Intel Xeon E5-2697 v3, with 8 GB RAM and 64bit Windows 7.

What is wrong with this tool!? My impression is, with each new SP it get's even more unstable at it is.



Accepted Solutions (0)

Answers (2)

Answers (2)

0 Kudos

Hi Rafal,

We have the same issue and we arrived a the same conclutions that you explain:

Check-in starts after minutes,

But we have also the proxy bugs (high number of connexions to the DB non working).

We have créated a oficiel incident to SAP. Her recommendation for us is the migration to the latest PD version, so we work on this.

Have seems that there are no date or plans to able PD to utilize mutil-core CPU Thanks for sharing your experience.

Look our caracterisitques.

We are running on 16.5 SP05 PL01, POWERAMC not PowerDisegner.

DBMS: Oracle 12c.

The local workstation is Intel Core i5 3.2 Ghz, with 8 GB RAM and 64bit Windows 7 Entreprise


0 Kudos

Hi Camilo,

upgrade to newest Version will not solve the issue. We have tested it with 16.6 SP05 PL01... same issue. When they don't know, what is going on in their software, they will always tell you: "You have to upgdare." or "This kind of issues are usually handled by consultants, who have much more experience with these".

We have also created an Incident, and we will escalate it as this is a no-go.

REgarding multi-core support: I don't think PD will ever be able to handle multi-code, as they would have to change the architecture of the application.

odivis2: did you guys created an Incident for this?



0 Kudos

Hi Rafal,

from time to time, I run into very similar problems with the same symptoms. And honestly, I don`t know either how to proceed. It would be great if someone from SAP could help us with that.

Perhaps you could add information about DB (and version) used for the repository and also about the checkin. Is it first time checkin, is it baseline checkin or standard incremental checkin (=not baseline)?

Regarding 50% CPU consumption... My observations are, that PD can utilize only one cpu core, so if you have quad core in your computer, PD can use only 25% of CPU performance. If you have hyper-threading enabled (virtual cores), you get only 12,5%. So another advice is to disable hyper-threading and use as few as possible cored CPU with as high as possible performance on one core. Another question to SAP: When will be PD able to utilize multi-core CPU?

0 Kudos

Hi Ondrej,

I have updated the original post with some additional information about DB Version, workstation configuration etc.

We will raise also an official issue via Launchpad, let's see what will happen. But the point is: they are always saying - "it's because you are not on the latest PD version".

But in most of the cases, it has (suddenly) nothing to do with the PD version we are using. It's simply a bug in the tool, a bug known since years, they are not able to fix. My impression is, it became even worse, after SAP has owned Sybase....